Server 2003 Profiles

Trying to create profiles for users.

Have created a folder and sharing it for the each profile to create itself.  With the proper credintials.

Have the users profiles point to \\server01\users\%username%

When the users login their profile directory is created, but not in the locaton above.  It is created under documents and settings.

What would be preventing the profile from being created where i want them and not the document directory folder.

goldmantechologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
Make sure you have the server's shares allowing Read/WRITE - default shares in 2003 do NOT permit writing.

Even so, with roaming profiles, the profile WILL be created locally, but it should be copied up to the network on logon - you might want to just try logging out first.
0
Netman66Commented:
OK...a few questions:

1)  The SHARE should be Authenticated Users - Full Control - is it?
2)  The NTFS permissions on the folder "Users" should be Authenticated Users - Modify, SYSTEM and Administrators - Full Control.  Uncheck Inherit permissions from parent and do not copy them - remove them.  Make sure to add the one's above first.
3)  The %username% folder that is created may not reflect the proper permissions since it inherits from Users.

Let me know.
0
Netman66Commented:
To add something...

The NTFS permissions can be set using Advanced button so that the scope of the permissions Apply to this folder only - therefore, they shouldn't be passed down to the actual user's folders when they get created.

However.....all other permissions such as Administrators and SYSTEM won't either.

I'm looking for the article that explains how to set this up so auto-generated folders have the correct permissions.

0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

goldmantechologyAuthor Commented:
Ok. When a new user logs in - It will only create the users profiles in the users directory.  For somereason it is also still creating them in the documents and settings?

0
Netman66Commented:
These are the NTFS permissions required on the "Users" folder to make this work:

Use the following settings for NTFS Permissions:
• CREATOR OWNER - Full Control (Apply onto: Subfolders and Files Only)
• System - Full Control (Apply onto: This Folder, Subfolders and Files)
• Domain Admins - Full Control (Apply onto: This Folder, Subfolders and Files)
• Everyone - Create Folder/Append Data (Apply onto: This Folder Only)
• Everyone - List Folder/Read Data (Apply onto: This Folder Only)
• Everyone - Read Attributes (Apply onto: This Folder Only)
• Everyone - Traverse Folder/Execute File (Apply onto: This Folder Only)
0
Netman66Commented:
On the Account tab of the User's account in ADUC you put this in:  \\server01\users\%username%

Correct?

It will always create a local profile - this much is normal.

If so, and the user logs into the domain, then it should create the %username% (John Smith for example) folder within the Users folder on the server.

I'm not sure if this happens at logon or logoff initially - I think it should do it during logon.

If the client workstations are XP then we may need to set this policy element:

Computer Configuration>Administrative Templates>System>Logon:: Always wait for the network at computer startup and logon = ENABLED.

This can be set on a new GPO linked to the Domain.
0
goldmantechologyAuthor Commented:
Why would it still be creating the profiles under the document and settings on the server everytime the user logs in? It is also creating the profile under the users folder.

Testing this via terminal services. Would that be the reason? If that is the case how do you fix that?
0
goldmantechologyAuthor Commented:
yes under account tab put that in. As well as terminal
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Yes, that's the reason - Terminal Services Logs you on locally.  That's standard and quite normal behaviour.
0
Netman66Commented:
Exactly.  The TS session creates a local profile.  BTW, we didn't have that information earlier!

I think there is a setting in Group Policy to delete this, but there's no point as it's created everytime - needless work on the server's part.

0
Netman66Commented:
There is a setting you can use.

On a GPO at the Domain level:

Computer Configuration>Administrative Templates>Windows Components>Terminal Services::Set path for TS roaming profiles.

You could set this to be the same profile as the the desktop - it should work fine.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
goldmantechologyAuthor Commented:
Where can i find the above settings?
0
Netman66Commented:
If you open up Active Directory Users and Computers on the Domain Controller,
Right-click the Domain
Select Properties.
Select the Group Policy tab.
Hit the New Button and name the new policy.
Press the Edit button after you name it and it will open in Group Policy Editor.
Follow the path above to find the setting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.