We help IT Professionals succeed at work.

Public Mailbox Store will not start

gregharmony
gregharmony asked
on
Medium Priority
805 Views
Last Modified: 2008-01-09
I'm running Exchange 2000 and it crapped out when the private and public edb files became as large as the hard drive

I moved the pub.edb file to another, ran the eseutil and then copied the file back to the exchange partition...

AND NOTHING HAPPENED.

I'm really not an Exchange guy but I figure if I could get through this jam with some help, then maybe I'll be on my guy to becoming an Exchange guy.
Comment
Watch Question

Commented:
What i could understand is that you are not able to mount your Public Folder store after a dirty shutdown. You repaired the pub.edb on another machine and put it back, still no success.
Please check the status of pub.edb now, using eseutil /mh and see, if its showing as a clean shutdown now.
If its a clean shutdown state, try to mount the store and check the application log, there should be some errors giving you an idea whats going wrong.
What about priv1.edb? is private store mounted successfully?

Thanks,
Amit Aggarwal.

Commented:
I believe you only moved the db when you saw it is filling up the hard drive. Am i right??

Did you changed the database path of public information store. If no you can do it now.

Also tell me the status of the db's after doing so.

Thanks
Kunal

Author

Commented:
I checked the status of the pub.edb and it is showing as a clean shutdown.

When i tried to mount the Public Folder Store, the error I received in the Application Log was:

Error 0xfffffde4 starting database "First Storage Group\Public Folder Store (Exchange Server)" on the Microsoft Exchange Information Store.
Failed to attach to Jet DB.

Additionally, the private store is mounted successfully because I didn't move the priv1.edb file

Also, I tried to change the path of the public information store and it wouldn't allow me to do so.

Commented:
Please have a look at KB -
http://support.microsoft.com/kb/289079/en-us
Cannot Mount Mailbox Store After Offline Defragramentation Error -540

Thanks,
Amit Aggarwal.

Author

Commented:
Before I try this, do I use the eseutil to copy the files back to their original location through DOS prompt?
Commented:
The path given in the properties of mailbox store and public folder store in Exchange System Manager should be poiting to the current (correct) location of priv1.edb and pub1.edb.

Thanks,
Amit Aggarwal.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Please forgive my ignorance, but the KB article says to locate the temporary files and copy them back to their original location and original names.

I really don't know where to locate the temp files

Commented:
Check on the drive where the defrag was run!

Author

Commented:
I finally found the drives...thanks a bunch! Now how do I go about copying the files back to the Exchange Server...the clean way and not the dirty way

Author

Commented:
Everything worked fine. Right now I'm trying to see the content of the public folders, but the entire structure including permissions restored, so I'm very hopeful.

I would like to thank everyone who participated in finding a workable solution for me.

Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.