How to Install fonts with user account set to "limited account"

I cant give the graphic designers on my job an administrator account because their win XP computers would not last more than a week before  they install some pirated softare or get a virus.

On the other hand they ask me all day long to install or uninstall fonts for their designs. It has come to a point where it looks like they are asking it just to get me tired so I finaly give them an administrator account.

Selecting a list of fonts every week or so is not an option because "the creative process has no time and can't be pre-programed".

Please help! Is there a program (or something else) that can install / uninstall fonts when used from a limited account.
juanjo_dicAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jkrCommented:
IIRC, giving them write access to %SystemRoot%\Fonts should be enough.
0
CyberneticsConnoisseurCommented:
Give their user accounts full access to the c:\windows\fonts folder.

That way, they can add/modify/delete fonts themselves by manual copy/paste/delete process. however, for the new font to be recognised by the system, it might require a system restart, though usually just a refresh (press F5 in explorer) works.
A font once copied, doesnt really require to be deleted (I wont know your reasons for it) and there are sites where more than 400-500 true type fonts are readily available for download. It would be a one time effort to download them all and install them once for all. Then they can use whatever they want and wont bother you repeatedly for new fonts.

Hope this works for you!
Do let me know the results or if you need further assistance...

Carpe Diem!
0
juanjo_dicAuthor Commented:
Sounds very good... how do I give them write access to the font folder? Using regedit?
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Mark BradyPrincipal Data EngineerCommented:
ok go to IE and click on Tools/Folder Options/View
Scroll down almost to the bottom where is says 'Enable simple files sharing(recommended)'  Now uncheck that boxx if it is checked.

Step two.   Navigate to the windows directory and right click the fonts folder.  Go down to properties and click that.

Net click the 'security' tab.  you should see a list of users in the box.  You must check 'Full Control' at the top of the box then apply or ok.  If you don't see any other users in there but the account you are on,, click the 'ADD' button and type in the usernames of each graphic user on the PC.  Use the 'check name button after each name to make sure you spelt it right.   Once you have set every users permission for the fonts folder they will be allowed to copy fonts into it or delete/modify as the above exxperts said.
Hope this helps

Elvin
0
CyberneticsConnoisseurCommented:
Start > Run ... type %windir% and then press enter.
The 'windows' folder will open up. Select the 'Fonts' folder to highlight it.
Right Click on it and select 'Sharing and Security'.

If the file system on your machine is NTFS you will see the 'security' tab, not on FAT32.

If NTFS, go to the 'Security' tab. The default group of 'Everyone' is visible.
Click 'Add' button to add the User ID's one by one or if they are part of a group, include the Group only.
(It is always a good practice to have all limited users under one group, that way you can apply restrictions or give rights to one group and all users in it will inherit it, saving you a lot of time and trouble of doing the same task for each one of them separately.)
Once you have added the group or all the users, give them full control rights. Apply > OK. Refresh/Reboot.

If FAT32, go to the 'Sharing' tab and click on share this folder. The 'Permissions' button will get enabled. Click it and it will give you the same option of adding users and assigning rights as written earlier.

Elvin's point of unchecking 'Enable simple files sharing(recommended)' is a good thing to check for before you do this coz otherwise you will see Network Share options instead of private setting.

Thats it ... job done.

Hope this works for you!
Do let me know the results or if you need further assistance...

Carpe Diem!
0
CyberneticsConnoisseurCommented:
BTW, that option of 'Enable simple files sharing(recommended)' will be under 'View' tab in Tools > Folder Options, that you get by opening "Windows Explorer", not "Internet Explorer". Elvin, small correction there.
0
Mark BradyPrincipal Data EngineerCommented:
oops yes I meant to say WE not  IE

Elvin
0
juanjo_dicAuthor Commented:
I'm using XP Home and I can't seem to find the option to deselect simple file sharing. Will this work on XP HOME?
0
CyberneticsConnoisseurCommented:
yes, it will .. go ahead with the direction i have described and lemme know if you face any issues.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LeeTutorretiredCommented:
If you don't see the Security tab, you will have to first disable Simple File Sharing in Windows XP Pro by clicking the Tools menu in Windows Explorer, selecting Folder Options, then the View tab, and then removing the check mark next to Use Simple File Sharing.  If you are using XP Home, then you will need to boot into Safe mode and login as Administrator to access the Security tab.
0
juanjo_dicAuthor Commented:
I cant find the option to deselect "simple file sharing" on windows XP HOME thus I don't see the Security Tab in the properties for the font folder.
0
LeeTutorretiredCommented:
Are you logging in as Administrator in safe mode?  And is your disk formatted with the NTFS file system?  You cannot disable simple file sharing if you're using XP Home, but you can still edit the permissions:

http://support.microsoft.com/default.aspx?scid=kb;en-us;304040
Description of File Sharing and Permissions in Windows XP
0
juanjo_dicAuthor Commented:
You need to install the security package downloadable at microsoft for XP Home. It actually adds the security tab in the folders options. Thank you all for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.