Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

the ordinal 6648 could not be located in the dynamic link library MFC42.dll

Posted on 2006-03-21
19
Medium Priority
?
1,196 Views
Last Modified: 2007-12-19
When I try to open WS-FTP I am getting an error message
the ordinal 6648 could not be located in the dynamic link library MFC42.dll

This has just happened.
Yesterday I installed a trial version of some software from a site
www.netstudio.com

Some of the help links at netstudio.com are not working.

I thought perhaps this may be causing a problem so I decided to unistall it.
However I cannot see it as available for unistalling.

I cannot find netstudio within Program Files where I thought it was installed although
there are two icons there
Net Studio Easy Web Graphics.GID and
Unistall Net Studio easy Web Graphics

If I try to open Unistall Net Studio easy Web Graphics I get error message
the following file does not exist e\program files\uninstal.log

I cannot open Net Studio Easy Web Graphics.GID either

Can anyone please advise me how to unistall the program and get WS_FTP going again.

Many thanks

John
0
Comment
Question by:johnhardy
  • 9
  • 5
  • 4
  • +1
19 Comments
 
LVL 2

Expert Comment

by:arvanius
ID: 16245763
If you are running Windows XP you could see if the installation of Net Studio
created a System Restore point, then it is easy to restore you computer to the
state it was before the installation of Net Studio.

Start->Run, Open: %SystemRoot%\system32\restore\rstrui.exe, OK

"Restore my computer to an earlier time", Next
In the calendar, select a system restore point from day that you installed Net Studio,
or a day or so earlier, next.

This does not mess with you files in "My Document" only Windows och Program Files
0
 

Author Comment

by:johnhardy
ID: 16245812
I did that and received ths message
System restore has been turned off.

**!!xxx!!
0
 
LVL 2

Expert Comment

by:arvanius
ID: 16246305
ok, that is to bad...

Restart the computer and try downloading and installing a fresh copy of  Net Studio,
and check for a uninstall entry in "Add o Remove Programs" in control panel,
or a uninstall shortcut in the Start menu, under Programs, Netstudio or so.

MFC42.dll is a common Microsoft file used by many programs,
it is updated by Sp2 for Windows XP, try installing that (again)
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:johnhardy
ID: 16246561
A little good news is that I re installed the netstudio and this time it appeared for removing.
So thats done.

How is it best to reinstall MFC42.dll?
I have a windows XP disc which I think includes SP2 but knowing very little of installing the OS am a bit reluctant to start.
Are there instructions for this anywhere?

Thanks John
0
 
LVL 6

Expert Comment

by:JimsZ
ID: 16246878
download it
copy it to windows system32 folder


http://www.dll-files.com/dllindex/dll-files.shtml?mfc42
0
 

Author Comment

by:johnhardy
ID: 16247200
Thanks,
I downloaded the file mfc42.dll and replaced the original.
I tried to run ws-ftp but still am getting the same error message.

I did a search on my C: drive for this file and found 3

MCF42.DLL in C:\Program Files\NavNT          not replaced
mfc42.dll in C:\Wndows\system32  (which I have replaced)
mfc42.dll in C:\Windows\WinSxS\x83_Microsoft.Tools.VisualCPlusPlus etc etc           not replaced

I have also found one in e:\Program Files or more is still looking

Should I replace the other two.
I also notice the first file has it name in Uppercase, is this significant?

Many Thanks
John
0
 
LVL 2

Expert Comment

by:arvanius
ID: 16247448
Try to register the file again using the command "regsvr32 MFC42.dll" in Start->Run.

I would not replace the MFC42.dll located in C:\Program Files\NavNT,
that could mess upp Norton AntiVirus and it should not affect WS-FTP

The file name in uppercase is not significant in Windows.

Start->Run, type in "winver" ok, the window will tell you what service pack version you have
(none, Sp1 or Sp2) my computer says "Version 5.1 (Build 2600.xxxxxx: Service Pack 2)

If you do not have Service Pack 2 use the shortcut on you Start Menu, Windows Update, to update.
0
 
LVL 5

Expert Comment

by:dclive
ID: 16247544
Confirm that by downloading and replacing the file, the file actually got replaced.  In other words, compare the date and filesize of the file you downloaded with what is in c:\windows\system32 and confirm they match exactly.

WFP (Windows File Protection) should prevent you from making changes to many protected system files, and I believe MFC42.dll is one of them.  You can boot in safe mode and change it, if you do discover that the two files don't match exactly.
0
 

Author Comment

by:johnhardy
ID: 16247576
Thanks
I notice that when ws-ftp fails to open it names the file in uppercase MFC42.DLL so does that make it likely that this is the faulty file?
0
 
LVL 2

Expert Comment

by:arvanius
ID: 16247686
I think it is better that you let Microsofts utilitys put in a good version of the file.

either install Service Pack 2 or you could try the file checker utility,
Start->Run, "sfc /scannow" (requires XP CD)

or perhaps you have the installation media for WS-FTP,
and you could reinstall it?

0
 

Author Comment

by:johnhardy
ID: 16247691
Thanks,
Quote
"WFP (Windows File Protection) should prevent you from making changes to many protected system files, and I believe MFC42.dll is one of them.  You can boot in safe mode and change it, if you do discover that the two files don't match exactly."

I reckon your right here C:\WINDOWS\system32\mfc42.dll shows at 1.004KB
and the downloaded file is 919KB
In safe mode, do I copy the files and paste it into C:\WINDOWS\system32
John
0
 
LVL 5

Expert Comment

by:dclive
ID: 16247992
Yes.  Then reboot in normal mode and try again.
0
 

Author Comment

by:johnhardy
ID: 16248250
Seems like thats made it worse.

I now get errors from
monitor.exe
ppActiveDetection.exe
SideAct.exe
Act.exe
as well as WS-ftp
All comiing up with the error
The ordinal 6680 could not be located in the dynamic link library MFC42.DLL
0
 
LVL 5

Expert Comment

by:dclive
ID: 16248539
OK, so what is the version of MFC42.dll, both the one you downloaded and the one that was originally present?  It's found in Properties/Version tab.

6.2.4131.0 is what I'm running with a modern XPSP2 machine; I suspect that's what you should run also.
0
 

Author Comment

by:johnhardy
ID: 16248715
Thanks
The version I downloaded is 4.21.0.7160

The version I replaced is 6.2.4131.0
Where would I get th latest version again please?
0
 
LVL 2

Assisted Solution

by:arvanius
arvanius earned 1000 total points
ID: 16248977
...

either install Service Pack 2 or you could try the file checker utility,
Start->Run, "sfc /scannow" (requires XP CD)

This utility will check that you have the correct version of system files,
and if not it will copy them from the XP CD
0
 

Author Comment

by:johnhardy
ID: 16249635
Thanks the scannow run well and it replaced the down loaded MFC42.dll to the original one.

However I still cannot open ws_ftp, same message

I did check the winver and it is SP2

0
 
LVL 5

Accepted Solution

by:
dclive earned 1000 total points
ID: 16249719
http://support.ipswitch.com/kb/VT-20010816-DM01.htm

Delete the MFC file, then reinstall the application.  

Worth a quick try...

You'll probably have to delete the file from within safe mode, then reboot, then uninstall & reinstall the app.
0
 

Author Comment

by:johnhardy
ID: 16250979
Thank you very much for all your enormous help.

I eventually got all the problems sorted out although I now have all the connections to recreate.

The last comment helped me to put this one to bed but it was still a bit complicatedhaving to re install ws-ftp before I could uninstall to re inistall.

I had looked on the ipswitch search and never found the above link.

I will split the points.

Thanks so much again.

Regards

John
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As the title indicates, I have done this before. It chills me everytime I update the OS on my phone, (http://www.experts-exchange.com/articles/18084/Upgrading-to-Android-5-0-Lollipop.html) because one time I did this and I essentially had a bricked …
Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question