• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3600
  • Last Modified:

USB Ports stopped working

A little while back it seems my usb ports on the back of my asus motherboard began to not work. now it's gotten to a point that next to none of them are working. On some of the ports my keyboard will light up but not be recognized or XP won't even attempt to recognize it. Like it's getting power but not recognizing data. On other ports nothing just dead. on another Xp will see something is there and say it's unrecognized or an error happened. I have some usbs on the front of my case that plug into motherboards onboard usb pins up until this morning one of those two ports was working.

I'm thinking this to be one of two things, a bad power supply (including possibly the 600w in there isn't enough watts) or a bad motherboard. I am hoping it's not the motherboard, but I need some way of testing or correcting this.

I looked at the power monitor in the bios and saw that the 12v was at about 12.3 and the 5v was either 5.3 or 5.5.  I'm not sure exactly what it should be or what it means, So I could use some enlightenment on the voltages and what they mean.

At times I have also gotten an error that says "Overclocking failed" however there is no overclocking occuring. Any ideas?

here are some details on my machine's specs....

Motherboard: P4C800-E Deluxe
Video Card: Sapphire Tech Ati radeon 9600 pro 256mb
Memory: 1GB Corsair XMS with LEd
Sound: Sound Blaster Audigy Gamer Limited Edition
Hard Drives 1: Hitachi 250gb SATA
Hard Drives 2: Maxtor 300gb SATA
Hard Drives 3: Maxtor 250gb SATA
CD/DVD: Samsung DVD+-rw
PCI Card: Silicon Imaging SATARaid controller (to handle the 3rd SATA drive)
Power Supply: 600W
CPU Fan: Cool Master Aerojet



Any input, tests or diagonosises would be awesome!

Thanks!
0
Isisagate
Asked:
Isisagate
  • 7
  • 3
  • 3
  • +7
2 Solutions
 
IsisagateAuthor Commented:
I should also mention the processor is a P4 3.0 GHZ Prescot with 800MHz FSB and HT
0
 
CallandorCommented:
Generally, 10% is the accepted variance for power supply voltages, yours seem to be within specs.  

- Your WinXP USB drivers may have gotten corrupted, which can be fixed by removing the USB controller drivers in device manager and letting reinstall on reboot.

- Your USB ports may be suffering from excessive power draw, which a powered USB hub may alleviate.

- Your power supply sounds like it's powerful, but it may not be putting out enough current under a heavy load.  Swap a different one in.
0
 
computerfixinsCommented:
I wonder if something your using is blowing up the usb ports, a bad memory stick or cable?

I doubt its a power supply issue, a quick test could be to unplug /remove un-needed items, extra hdd, sounds cards, etc.  Then boot and test.

600 watts should be plenty, only times I've seen the need for more is in the dual video card setups or if your running a ton of drives...

May want to try reseting the cmos/bios, (just something to try.)

As long as the voltages are with-in a -/+1V for 12 -/+ .5 for 5 spec usaully... 3.3V line is a little more sensitive...

0
What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

 
computerfixinsCommented:
doh!; callandor types faster then i do
0
 
f-kingCommented:
Hi
Try reinstalling windows or starting it in safe mode and see if the errors still persist.
Uninstall the usb ports and keyboard from device manager ,and see what happens if there are no good results
then It will definitely be the motherboard ,and to be honest it really sounds like it.

Good Luck
0
 
IsisagateAuthor Commented:
Well I don't think it's an operating system problem as I had reinstalled the system a week ago to try and fix this but no luck. I've been thinking maybe it's the USB ports not getting enough power, if that's the case would a larger power supply be usefull?
0
 
f-kingCommented:
Well it looks like it is definitely a Motherboard problem
You should get a new one or see if that one has any warranty on it and change it if they let you.
0
 
Intense_AngelCommented:
go into the device manager>view>show hidden devices....delete the offending usb ports and reboot.  Sometimes you need to run flush commands for the usb ports, and I have the instructions from microsoft on how to do it...just not with me.  But I have seen this many times, for some reason the usb port or OS holds onto old info and will not let you use it anymore.  My computer has done every few months, just depends on how many usb devices you plug in and out...by the way it does this with firewire sometimes to.

Anyway do the above reboot and you will see them re-added.

Good luck.
0
 
IsisagateAuthor Commented:
I could totally use those instructions to try if you can find them
0
 
Intense_AngelCommented:
I will try...I have them on another computer at home, so if I cannot find them again online then I will get them to you tomorrow.
0
 
tim_quiCommented:
Hey,


try turning off the system, then upplugging from the power supply ( the electrical wall socket) for 30 minutes.  Then turn it back on and try.  Also go into device manager,usb root hub, power management, make sure power management is turned off.
0
 
Intense_AngelCommented:
I found it....this has worked on a few machines now for me.

Step 1: Remove Hidden Devices

1. Open a Command Prompt.
2. Type "set DEVMGR_SHOW_DETAILS=1" (without quotation marks) and press Enter.
3. Type "set DEVMGR_SHOW_NONPRESENT_DEVICES=1" (without quotation marks) and Press Enter.
4. Type "start devmgmt.msc" (without quotation marks) and click press Enter.
5. Click View. Click Show hidden devices.
6. Click "+" to expand devices, Unknown devices and USB devices.
7. Are there any devices and unknown devices (including grayed out devices)? If so, please right click it and click Uninstall them.

Step 2: Remove all oem*.inf files

=========================

1. Click start and click run then under the run line type in the command "cmd" (without the quotation marks)

2. In the command line, type in the following (without the quotes) and press enter after each command:

"cd \windows\inf"
"ren infcache.1 *.old"
"ren oem*.inf *.old"
"del C:\windows\setupapi.log"
"exit"

Step 3: Removing all entries under HKEY_LOCAL_MACHINE/Enum/USB that start with VID using REGEDIT.

==================================================================

Removing the VID entries from the registry will cause them to be redetected at restart.

CAUTION: If you have a USB keyboard, mouse, scanners, and other things you know are working, do not remove the VID entry for these devices, otherwise, Windows may not restart correctly.

1. Click Start and click Run. Type regedit and click OK. The Registry Editor window will open.

2. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB.

3. Highlight and delete all the VID_.... entries for usb devices that you cannot identify. Remember not to delete the entries mentioned above.

You may not have permssion to delete keys, do the following.
Permissions may be set allowing the deletion of the VID_ entries by following the steps below:

a) Right-click the key to be deleted, and then click Permissions. The VID_... Permissions window will open.
b) With Everyone highlighted in the Group or User name section, select Full Control in the Permissions section.
c) Click Apply, and then click OK.

5. Restart your compuer.

Step 4: Reconnect the USB device that was not previously working. Windows should automatically rerinstall the drivers.


This worked for me and hope it helps you out. Good luck with it.
0
 
haim96Commented:
try to reset your bios setting (with "clear cmos" jumper)
then make sure  that your usb ports are enable (in the bios)
if still not working and you alredy tried to install fresh XP then
somthing defently wrong with your hardware. (PSU or MOBO )
0
 
computerg33kCommented:
The controllers for the usb ports are probably blown now.  So yes its a motherboard problem now, however I believe it is also something your plugging into those slots that is blowning the ports on the motherboard.  I would suspect its your keyboard if the port works and then doesnt work after awhile of having the keyboard plugged into it.
0
 
IsisagateAuthor Commented:
Awesome I will try it tonight, hope it works cause I don't want to buy a new motherboard if I can avoid it =)
0
 
IsisagateAuthor Commented:
The keyboard is a saitek gamer keyboard with the macro pad, it installs a ton of drivers for HID devices when you plug it in and infact is very annoying in that reguard. Mouse I have a logitech Mx800 (the wireless rechargable one) other usbs are a scanner and printer.
0
 
haim96Commented:
if all your port are dead and you don't want to replace mobo
you can alway buy pci card with USB ports. and plug it to usb hub.
it's chiper ! :)
0
 
IsisagateAuthor Commented:
hey good one! =)


provided what ever might have blown them doesn't blow those too....


Anyone able to give me an idea what could cause the USBs to be blown?
0
 
haim96Commented:
you should replace the port with the  pci card only after
you  find out what cause them to blow :)

and about the cause to blowen usb: it can be a faulty computer PSU
or even faulty power suplay from any usb device like scaner,printer etc or
0
 
IsisagateAuthor Commented:
gotcha, thanks =)
0
 
tim_quiCommented:
be sure to try my suggestion about  unplugging it for 30 minutes. I know it sounds crazy, but I've seen it work before.  It has something to do with letting the board circuitry discharge residual current.
0
 
CallandorCommented:
Excess power draw from devices can blow a USB port, which is another advantage of powered USB hubs - they can handle heavier loads.
0
 
computerfixinsCommented:
Funky usb memsticks are "infamous" for frying usb ports.

To double check if its a operating system problem you can load up a knoppix cd...

just download image, burn and boot off cd:)

http://www.knoppix.net/
0
 
compfixer101Commented:
www.badcaps.net   could be your problem  check it out

cf101
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 7
  • 3
  • 3
  • +7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now