• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3039
  • Last Modified:

Get rid of "Local Area Connection" notification Icon.

My laptop is frequently not connected to the Local Area Connection at my office.  I customize notifications so it always hides but when it is not connected, the "Local Area Connection" notification Icon shows up after every time I return from standby or hibernate.  A Microsoft engineer sang the M$ mantra, "This is by design."  I have tried the registry edit in http://Q_20279060.html#6882150 with no help.  I Know it is a small issue but it is really bugging me.  I tried black tape but the #+%! thing keeps moving.  Any ideas?  I wouldn`t mind if I never saw that icon again!
0
thenelson
Asked:
thenelson
  • 4
  • 3
  • 2
  • +4
1 Solution
 
mediamaxCommented:
I am not sure whether you had disable MediaSense. If you have tried it. Heres an option to disable all notifictions

1. Click Start, Run and type regedit

2. Navigate to the following subkey:

HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ Advanced

3. In the right pane, create a DWORD value named EnableBalloonTips

4. Double-click the new entry, and give it a value of 0.

5. Quit Registry Editor.

6. Log off Windows, and then log back on for the changes to take effect.


0
 
essaydaveCommented:
Have you tried customising your system tray as well?  Right click on some empty area on your taskbar and select Properties to bring up the Taskbar and Start Menu Properties.  In the Taskbar tab, ensure that "Hide Inactive Icons" is checked, and then click on Customise.  Select Local Area Connection, and choose "Always Hide" from the dropdown. Should do the trick...
0
 
thenelsonAuthor Commented:
mediamax,
I don't want to disable all notifictions.

essaydave,
>Select Local Area Connection, and choose "Always Hide" from the dropdown.
That's what I do EVERY time I return from standby or hibenate (about 40-50 times per day when I am running on batteries.)
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
essaydaveCommented:
I know this is obvious and you've probably done it, but in the network connection's properties have to deselected the option to "Notify me when this connection has limited or no connectivity"?  
0
 
x_X_x_X_xCommented:
Go to Start, Control panel, double click network connections, right click Local are connection, Choose properties and remove the check at the bottom that says Show icon notification when connected and if you have SP2 you will want to remove Notify me when this connection has limited or no connectivity as well....Hope this helps.
0
 
thenelsonAuthor Commented:
>"Notify me when this connection has limited or no connectivity"
Not checked.  (Guess Windows doesn't believe I mean it.)
>Show icon notification when connected
Also not checked.

 x_X_x_X_x,
I have to ask:   x_X_x_X_x???   Story behind that??

BTW: Welcome to EE!!
0
 
KenneniahCommented:
One slightly annoying workaround would be hardware profiles. Create one for when out of the office that has the network card disabled.
0
 
mediamaxCommented:
thenelson,

I suspect the issue is with address resolution protocol cache.

I had a similar issue loosing connectivity on resuming from standby. I found a workaround to run the following command when i resume from standby

arp -d ip_address

i am not sure if this works on your system. Anyways worth giving a shot..

Good luck
0
 
M_IntuitCommented:
I get that... but only on an intermittent basis... I never thought about why until I saw your post.

I tend to disable any of the "network adapters" via Device Manager and/or "Network Connections" when not in use.  I believe that whether or not that notification shows for me, is dependant upon whether or not that particular adapter is disabled.  I don't usually initiate the sleep/hibernate/shutdown process while still connected and so most of time I don't get that wierd notice.  Since I'm not connected, I disable the devices... WLAN, LAN, 1394, & sometimes even the modem.

There are scripting applications that you can use to assign a hotkey to a macro that will enable/disable those adapters.  I use Macro Express... WWW>Macros.Com.  But there is also ... http://www.snapfiles.com/freeware/system/fwauto.html
0
 
x_X_x_X_xCommented:
Thanks thenelson I appreciate the greeting.....Sorry to disappoint but there is no real story other than the fact it is a unique id that I use other than my full name....which I only use at certain sites...So no dirty little secrets behind it .....lol
0
 
thenelsonAuthor Commented:
I finally got around to trying out disabling the local network driver and that worked.  I created a shortcut to toggle enabling/disabling using www.hotkey.master.

Thanks M_Intuit
And thanks to everyone else for your suggestions.  Sorry about the delay.
0
 
BodragonCommented:
This behaviour is a bug in XP SP2 that is recognized by Microsoft. There is a workaround, though. See
 http://support.microsoft.com/kb/902974 for further info
0
 
thenelsonAuthor Commented:
Thanks for the link. I have already tried this but the icon still comes back after returning from standby.
0
 
M_IntuitCommented:
Wow, this is an oldie.

I've two links on my desktop that literally allow me to enable and disable adapters accordingly.

The tool is called "DevCon.Exe" from Microsoft.  The instructions for usage aren't entirely clear but once you figure it out it's quite easy.  Right now "playing" around in Vista64 but when get back to XP32 I'll post a few commands as examples.
0
 
M_IntuitCommented:
Scenario:  Wanted link to disable/enable network adapter using DevCon console tool.

Console command to find network adapter hardware ID:
devcon findall *|find /i "realt"

Command output:
PCI\VEN_10EC&DEV_8133&SUBSYS_3056203C&REV_10\2&13817188&0&30F4: Realtek RTL8139/810x Family Fast Ethernet NIC
ROOT\CNTX_VPCNETS2_MP\0011                                  : Realtek RTL8139/810x Family Fast Ethernet NIC - Virtual Machine Network Services Driver

Console command to disable adapter:
devcon disable "*VEN_10EC&DEV_8133&SUBSYS_3056203C*"

Console command to enable adapter:
devcon enable "*VEN_10EC&DEV_8133&SUBSYS_3056203C*"

Similar sequence was used to find and create a command for the BroadCom "WLAN" adapter.  For whatever reason it was necessary to first "ipconfig /release" prior to disabling the last remaining network adapter because if I did not, then Windows would fail to obtain or renew an IP address with any DHCP server until a reboot.  Problem was intermittent, but releasing prior to disabling seemed to keep this 'bug' from reoccuring altogether.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 4
  • 3
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now