pkgadd -d /path



I get the following error message when I run pkgadd -d /path

pkgadd: error : no pkages were found.....


If I specifiy a file name like pkgadd -d /path/mypakagename1.local in this command then it works.

I have a list of packages that I woud like to have it install by runing one command.
razaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yuzhCommented:
you can do:

cd /path-to/
for pkg in * ; do
    pkgadd -d $pkg
done

or use a text file to put the package list in the file:
eg:
pkg1
pkg2

then do:
for pkg in `cat mylist`
   pkgadd -d $pkg
done
   
razaAuthor Commented:
This will work if I just neeh to untar or anything else like that.

when you run pkgadd -d command it ask you if I need to install all package or select a number.

I thought it should read all the package from the  directory and then allow me to select all or one.
yuzhCommented:
>>I thought it should read all the package from the  directory and then allow me to select all or one.

You need to write a script to do the job. You can post another question in:
http://www.experts-exchange.com/Programming/Programming_Platforms/Unix_Programming/

See if any experts have time to write one for you.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

sugarfreelessCommented:
try pkgadd -d .
sugarfreelessCommented:
while in the dir with all the pkg's that is
razaAuthor Commented:

I already tried this command but it did not find any package. but if specify a file like pkgadd -d filename then it works.


XoFCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.
I will leave the following recommendation for this question in the Cleanup topic area:

Accept: yuzh

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

-XoF-
EE Cleanup Volunteer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.