[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco  Bridge Virtual Interface (BVI) help

Posted on 2006-03-21
9
Medium Priority
?
8,721 Views
Last Modified: 2008-03-06
I am missing something in my configruation I think. I have the T1 up on the controller and the BVI1 group in place I just can not get the two to talk across the T1.
Help..

Here is my current config for both routers - everything is the same except the BVI1 IP address -

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXx

!This is the running config of the router: 10.10.10.2
!----------------------------------------------------------------------------
!version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EFHQ
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$9GD6$aAvKVq9du0975bo5P8bx6.
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -6
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip domain name mydomain.local
ip name-server 192.168.1.5
ip name-server 192.168.1.31
!
username CEF2841 privilege 15 secret 5 $1$Yl3F$xRGbmcCyuLxMtcLa4XKli1
!
!
controller T1 0/0/0
 framing esf
 linecode b8zs
!
controller T1 0/0/1
 framing esf
 linecode b8zs
bridge irb
!
!
interface FastEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface FastEthernet0/1
 description $ETH-LAN$
 ip address 10.10.10.2 255.255.255.0
 duplex auto
 speed auto
!
interface BVI1
 ip address 192.168.1.58 255.255.255.0
!
ip classless
!
ip http server
ip http authentication local
ip http timeout-policy idle 5 life 86400 requests 10000
!
disable-eadi
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner login ^C
EdgarFilings
^C
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
end


XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX


Thanks
0
Comment
Question by:webchrysalis
  • 5
  • 2
  • 2
9 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 16252471
The serial port connected to the T-1 has to be a member of bridge-group 1.

-Don
0
 

Author Comment

by:webchrysalis
ID: 16252733
I have a T1 controller card   - no serial ports -
0
 

Author Comment

by:webchrysalis
ID: 16253058
Disreguard the last comment,  still new at this , I created  my channel group and now have my serial 0/0/0:0 to address. I put the serial into the BVI1.

configured the other the same and  still canot ping across .  Any push in the right direction will help,

Thanks,

Eric
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 7

Expert Comment

by:minmei
ID: 16253378
You do have two different ip addresses, one on each side?

When you ping, do a specific ping "type ping at the prompt and choose the extended commands which lets you pick the source interface for the ping"
from the bvi ip interface. You may not have routes to the other 10.0.0.x network and that could be stopping your ping traffic.

Good luck!
0
 

Author Comment

by:webchrysalis
ID: 16254688
Here is the config:
My problem currently is  I can ping the following  on both routers only on the local side:
 
10.10.20.x     BVI
192.168.1.x   FastEthernet0/0

can not ping the serial 0/0/0:0  10.10.10.x from any router.
T1 line is up and no errors and serial is also up.


Also - I have both ends with timing for the conrtoller T1 Wic as line . I thought one should be line and one internal?  



updated config:

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx




ersion 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname EFHQ
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
no logging buffered
logging console critical
enable secret 5 $1$9GD6$aAvKVq9du0975bo5P8bx6.
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -6
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip bootp server
ip domain name xxxx.local
ip name-server 192.168.1.5
ip name-server 192.168.1.31
!
username CEF2841 privilege 15 secret 5 $1$Yl3F$xRGbmcCyuLxMtcLa4XKli1
!
!
controller T1 0/0/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
 description PPP for HQ end
!
controller T1 0/0/1
 framing esf
 linecode b8zs
bridge irb
!
!
interface Tunnel1
 no ip address
!
interface FastEthernet0/0
 description Local LAN for HQ
 ip address 192.168.1.57 255.255.255.0
 duplex auto
 speed auto
 bridge-group 1
!
interface FastEthernet0/1
 description $ETH-LAN$
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 shutdown
 duplex auto
 speed auto
 no mop enabled
!
interface Serial0/0/0:0
 description SERIAL for HQ
 ip address 10.10.10.2 255.255.255.0
 bridge-group 1
!
interface BVI1
 ip address 10.10.20.2 255.255.255.0
!
ip classless
ip default-network 192.168.1.0
ip route 192.168.1.0 255.255.255.0 192.168.1.58
ip route 192.168.1.0 255.255.255.0 10.10.10.1
!
no ip http server
ip http authentication local
ip http timeout-policy idle 5 life 86400 requests 10000
!
no logging trap
disable-eadi
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner login ^CEdgarFilings

^C
!
line con 0
 login local
 transport output telnet
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 4000 1000

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx


Thanks,

Eric

0
 

Author Comment

by:webchrysalis
ID: 16254702
Add on for clarity:

Router 1

FastEth0/0         192.168.1.57
Serial0/0/0:0     10.10.10.2
BVI                   10.10.20.2

Router 2

FastEth0/0        192.168.1.58
Serial0/0/0:0    10.10.10.1
BVI                  10.10.20.1

Thanks ,
Eric
0
 
LVL 7

Expert Comment

by:minmei
ID: 16256395
Maybe I'm more confused now.

You want this connection bridged becaused you have the same subnet on both sides of the T1?

You would use a bridge interface (BVI) when you are not routing between interfaces, just doing media conversion.  So if you want 192.168.1.0/24 to be on both sides of the T1 (I assume from your router fast ethernet addresses), then:

Router 1

FastEth0/0         No ip address, bridge-group 1
Serial0/0/0:0     No ip address, bridge-group 1
BVI                   192.168.1.57

Router 2

FastEth0/0         No ip address, bridge-group 1
Serial0/0/0:0     No ip address, bridge-group 1
BVI                   192.168.1.58

Then you should be able to ping .57 from .58 and anything else in the 192.168.1.0/24 network.

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16256640
I'm with minmei on this (confused).

If you want the same subnet at both locations, and no other IP requirements, you don't even need IRB. Just bridge the traffic.

-Don

0
 

Author Comment

by:webchrysalis
ID: 16262041
my goal was to route and bridge on the same router - I will be routing protocols and restricting them also thru the router.

Thanks  all the information has been a great help ,

Eric
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question