Windows Authentication without a second login on ASP.NET WebForms

I have an ASP.NET (Visual Studio 2003) application that uses windows authentication.  IIS is running on our company Intranet server which runs Windows Server 2003 and IIS 6.  We also use Active Directory.  When you open the start page it prompts you to login using the same information you already used to get logged on to the network.  Since the user is already “in”, how can I prevent the IIS server from prompting for their credentials again?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

go to iis > right click your application folder > Properties > go to "Directory Security Tab" > select "Integrated Windows Authentication

REmember to uncheck the other options.
Does this application has several applications inside with separate web.config?

remember to uncheck "Anonymous Access".

BTW, under "directory security" > you need to click "Edit" to go to "Authentication" windows where you can select "Integrated Windows Authentication" and uncheck "Anonymouse Access" and also uncheck "Basic Authentication".

Think currently your "Basic Authentication" is ticked.
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

geekboystevesAuthor Commented:
Nauman Ahmed,
The app has its own web.config file and its own virtual directory in IIS.

We already had all the directory security options set as you suggested.  We think the problem might be that we are hitting the server through the internet even though it's on our intranet, so we're trying to see if we can get a different server that is on the LAN instead of that one.  I'll post back with more information.  It may be that there is no problem if we get to IIS through a private IP instead of a public one, you think?

Even if you use Private IP it will still prompt you for user-pwd. But if you use the name of the server instead of IP Address, windows authentication will work fine.

Also in some of the IE Internet Options - Security - Custom Level - At the bottom of it - User Authentication - Prompt for Username and Password is selected then browser will always prompt for user/pass no matter what.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
geekboystevesAuthor Commented:
from AJesani> "Even if you use Private IP it will still prompt you for user-pwd. But if you use the name of the server instead of IP Address, windows authentication will work fine."

That was the magic bullet!  Once we started using the server's name instead of its IP address, the login went away entirely and all my System.Security.Principal code worked perfectly.  That was the only change required.  No change to the code whatsoever.

Thanks for the heads-up about the IE options too.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.