We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

jDeveloper - In a real Pickle??? Help

BenClark
BenClark asked
on
Medium Priority
1,493 Views
Last Modified: 2012-06-21
I have just inherited a web app that was written jDeveloper 10.
I have the source code and the jDeveloper IDE.
How do get started? I know the app compiles into ear files, but how do I setup
the app in the IDE and debug it?

Any help or suggestions would be greatly appreciated.

Thanks
Ben
Comment
Watch Question

Commented:
Hi Ben,

Questions   ???

Have you tried to put it into an IDE that you are using? And what problems are you experiencing?
 
OR

Can you show the program here if it is not too long or can you give a  URL so as to be able to download it for study ?

Also, what is the meaning of  " into ear files" written above?

Delphi3

Author

Commented:
I tried loading it into the jDeveloper IDE.
It wants a startup file. I don't know which file that would be.
The entry point on the web server is the Index.html file. jDeveloper won't let
me pick that as a startup file.

The web site is an internal site for the company so I can't give you a URL.

When the old programmers were done with changes, they would compile the code
and jDeveloper would produce a .ear file. This file is placed on the Unix web server.
Thats all I know about it.

What I need to know is,
1. What would typcially be a startup file? I am asuming this would be a java script????
2. Is there something particular in a startup file that I can look for to identify the startup file?
3. Any other info that could possibly help me get started.

Thanks

Commented:
Hi Ben,

I know how frustrating things can be.  Really!!

Here is sources for your Q's  for "what does this mean? ".

option 1.
http://mindprod.com/jgloss/jgloss.html

look at Java definitions: 0-9 A......Z

Take your time and browse around in the Java alphabetical listing of terms. I went to  "S" for startup.    It should put you on the correct track.

You can write the Roedy for further comments.


  OR  

Option 2.
http://www.jguru.com/

register (it's free) and then search for "Startup file"
a lot more to read.....

Delphi3




Commented:
Hi Ben,

Have you had any progress on your search for a Startup file?

Delphi3

Author

Commented:
No

Commented:
Ben,

Without revealing what the program is (because it is not possible according to you),  show a list of errors that are shown when you attempt to compile the program,  then,  when you attempt to run the program. The entire list from each listing would be appreciated.

D3
 

Author

Commented:
This is what i get when i try to compile.

[Starting OC4J using the following ports: HTTP=8988, RMI=23891, JMS=9227.]
****  Unable to obtain password from principals.xml.  Using default.
C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\config>
"C:\Program Files\jDeveloper 1013\jdk\bin\javaw.exe" -ojvm "-Doracle.home=C:\Program Files\jDeveloper 1013" -classpath "C:\Program Files\jDeveloper 1013\j2ee\home\oc4j.jar;C:\Program Files\jDeveloper 1013\jdev\lib\jdev-oc4j-embedded.jar" -Djdbc.connection.debug=true -Xverify:none -DcheckForUpdates=adminClientOnly -Doracle.application.environment=development -Doracle.j2ee.dont.use.memory.archive=true -Doracle.j2ee.http.socket.timeout=500 -Doc4j.jms.usePersistenceLockFiles=false oracle.oc4j.loader.boot.BootStrap -config "C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\config\server.xml"
[waiting for the server to complete its initialization...]
2006-03-30 10:34:18.646 NOTIFICATION Auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\dms.war...
2006-03-30 10:34:18.677 NOTIFICATION Unjar C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\dms.war in C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\dms
2006-03-30 10:34:18.677 NOTIFICATION Finished auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\dms.war
2006-03-30 10:34:18.740 NOTIFICATION Auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\connectors\datasources\datasources.rar...
2006-03-30 10:34:18.740 NOTIFICATION Unjar C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\connectors\datasources\datasources.rar in C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\connectors\datasources\datasources
2006-03-30 10:34:18.818 NOTIFICATION Finished auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\connectors\datasources\datasources.rar
2006-03-30 10:34:18.833 NOTIFICATION Auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j.ear...
2006-03-30 10:34:18.833 NOTIFICATION Unjar C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j.ear in C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j
2006-03-30 10:34:18.943 NOTIFICATION Finished auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j.ear
2006-03-30 10:34:18.958 NOTIFICATION Auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j\webapp.war...
2006-03-30 10:34:18.958 NOTIFICATION Unjar C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j\webapp.war in C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j\webapp
2006-03-30 10:34:25.377 NOTIFICATION Finished auto-unpacking C:\Program Files\jDeveloper 1013\jdev\system\oracle.j2ee.10.1.3.36.73\embedded-oc4j\applications\bc4j\webapp.war
06/03/30 10:34:25 [SEVERE]: Error instantiating application at file:/C:/Web/merlin/merlin-oc4j-app.xml: Unable to get ApplicationConfig for current-workspace-app : C:\Development\Merlin\Web\merlin\merlinApp\merlin\META-INF\principals.xml is absolute path
2006-03-30 10:34:33.967 ERROR J2EE HTTP0004 Internal error raised tyring to instantiate web-application: merlin defined in web site OC4J 10g (10.1.3) Default Web Site. Application: current-workspace-app does not exist. Error creating Web application: merlin
Ready message received from Oc4jNotifier.
Embedded OC4J startup time: 29205 ms.

Target URL -- http://192.168.101.107:8988/merlin/index.html
06/03/30 10:34:34 Oracle Containers for J2EE 10g (10.1.3.0.0)  initialized
Commented:
Hi Ben,

Let me take a few very long guesses. You need a password to access this program.  The data files are still on the website.  It can't find a work space.

My advice is to find the original author,  make suitable requests to access the program and permissions to change it.

That said, I am at a loss to recreate this startup file.  

I therefore request that you ask "community support" at EE here to close this particular Q and refund you your points completely. I cannot help you.

 

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks for your honesty.
I'll give you A for effort and the points for trying.

Thanks

Commented:
Thanks very much,

I really appreciate your generosity.

D3
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.