?
Solved

connect multiply vlans

Posted on 2006-03-21
3
Medium Priority
?
417 Views
Last Modified: 2008-01-09
i have 2 remote offices

mean office use hp procurve switch 2848 that is connected to a cisco 2600 router

remote office use hp procurve switch 2524 that is connected to a cisco 1700 router

in both the switchs (in main office and in remote office) i configured 2 static vlans (vlan 1 and 2 in main office switch and vlan 1 and 2 on remote office switch). also i configure the port that is connected to the routers (on both switchs) as trunking port. i can reach from vlan1 in main office the vlan 1 in remote office but i can not reach from vlan2 in main office the vlan 2 in remote office

the respectiv ip address for each vlan are

main office switch
vlan1 10.0.0.201 255.255.0.0
vlan2 192.168.1.201 255.255.255.0

remote office switch
vlan1 10.1.0.201 255.255.255.0
vlan2 192.168.2.201 255.255.255.0

i'm waiting forward for an answer
0
Comment
Question by:luani
  • 2
3 Comments
 
LVL 7

Accepted Solution

by:
minmei earned 2000 total points
ID: 16253348
Well, your subnets are distinct (they don't overlap). That's good.

I need to know what routes exists in each router. They should each know about both vlans local to each. If you have them on switch ports that are trunked, I'm assuming you have subinterfaces set up on the local fastethernet interfaces on each router, one per VLAN. If so, then the only missing element is getting routes for each site's network to the other site's router. Statics will work or a routing protocol like EIGRP or even RIP in this relatively simple network. I would go with the static routes.

Let me know if you need specific help with the subinterfaces or with the routes or both. Posting configs may help as well...

Good luck!
0
 
LVL 7

Author Comment

by:luani
ID: 16266718
Current configuration : 1125 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname EB_HeadQuarter
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
enable secret 4324sdfsadfa769a5s9df59asd5f
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!


!
!
!
controller E1 1/0
 channel-group 0 timeslots 1-4
!
!
interface FastEthernet0/0
 ip address 10.0.0.200 255.255.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
!
interface Serial1/0:0
 description *"EB_HQ 4timeslots to AAA"*
 bandwidth 256
 ip address 10.10.9.1 255.255.255.0
 encapsulation frame-relay
 frame-relay interface-dlci 101

frame-relay interface-dlci 103
!
ip http server
ip classless
ip route 10.1.0.0 255.255.255.0 10.10.9.2
ip route 10.1.1.0 255.255.255.0 10.10.9.3
!
!
!
line con 0
line aux 0
line vty 0 1
 password 7 14321F1B0344223A647862756C
 login
line vty 2 4
 password 7 120F0419110419122F39
 login
line vty 5 15
 login
!
!
!
end

The configuration of the router is a above.

i started to configure the subinterfaces but the encapsulations command was not available and was not possible to give ip addresses to subinterfaces

what can i do? (may be i need to upgrade the IOS of the router?).

thanks for your answier. was the one that i wanted

0
 
LVL 7

Expert Comment

by:minmei
ID: 16268108
If the 1700 is a 1721 or 1751, it should be able to do the dot1q encapsulation - the 2600 should be able to do the dot1q encaps.

Article:  http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a008008742b.html

This article is for IOS 12.0 - there should be others for the release you are on (12.3), but I can't find them right now.

0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question