We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

UNC Authentication

obliv2k3
obliv2k3 asked
on
Medium Priority
649 Views
Last Modified: 2008-02-01
Hello ladies and gents.

I am getting a problem with one of my windows 2003 SP1 server machines.
When you normall UNC to a 2003 server not joined to a domain you get asked for login credentials to view the shared resources, however after running the recent windows updates and bringing it fully up to date i can no longer UNC to the machine. IE i goto \\ServerName\ or \\ServerIP\ and normally at this stage i would get asked for a login. now for some reason something has changed which is stopping this feature.

Any ideas what could be causeing it?

I guess one idea might be to look for how to dissable this feature on a stand alone machine and work it backwards if that would work...

The machine is running IIS and is an application server for Quality Workbench so naturally you need to be able to access a shared resource for the client program to run/update. If you've had expereince with the utility.

This is rather urgent so if anyone could help me it would be appreaciated.


*** Edit ***

I've just found out that if i UNC to \\ServerName i get asked for the login credentials but not when i goto \\ServerIP
I need to be able to use the server IP as NetBeui names cannot be translated across our WAN.
Comment
Watch Question

Jeff BeckhamEngineer
CERTIFIED EXPERT

Commented:
Have you used the /savecred option for mapping drive to that box before?  It sounds like maybe your password has expired/changed and the savecred option might be passing bad password for one unc path or the other.  You might just have to re-save the credentials with the new password.  Otherwise, see this link for help in possibly removing it:

http://groups.google.com/group/microsoft.public.windowsxp.security_admin/browse_frm/thread/6ac8c18004100f30/81d3de38fa1c20e1?lnk=st&q=%2Fsavecred+remove&rnum=4&hl=en#81d3de38fa1c20e1
obliv2k3Business and IT Systems Engineer

Author

Commented:
No i havent.
I've tryed accessing the box on different machines to no success.
Jeff BeckhamEngineer
CERTIFIED EXPERT

Commented:
I understand that you are able to access it via hostname/netbios name.  Is that name resolving to the same IP address as you're trying to use?

Does the server have more than one NIC?  Maybe there's some sort of routing issue?

Have you tried rebooting the server?
obliv2k3Business and IT Systems Engineer

Author

Commented:
It has only one NIC.
will not resolve the IP only the ServerName
Jeff BeckhamEngineer
CERTIFIED EXPERT

Commented:
When I say resolve, I really mean when you ping the server, what IP address does it come back with?  An alternative to pinging the machine would be to use nslookup to resolve the name to IP.

What I'm getting at here is verifying that \\<server_name> is really doing the same thing as \\<server_ip>, as I see no normal reason as to why you would be able to get to \\<server_name> and not \\<server_ip>.
obliv2k3Business and IT Systems Engineer

Author

Commented:
The server has a static IP and is running IIS which looks to the IP and not servername.

Its confusing as to why the machine will not resolve to server IP however server name is fine.
Jeff BeckhamEngineer
CERTIFIED EXPERT

Commented:
Can you ping the server by name and by IP?  If so, when you ping the server by name, what IP address responds, and does it correspond to the IP address that you're using?  I'm trying to rule out name resolution problems.

You brought IIS up here for the first time.  Are you trying to connect via a UNC path (\\<server_name>) or via your web browser using a URL (http:\\<server_name>)?  This make a big difference.

You stated that the server is a stand-along server, not a member of a domain.  You have a local account on the server?  Also regarding the machine that you're trying to connect from, are you logged on with an account with the same name/password that exist on your remote server?
obliv2k3Business and IT Systems Engineer

Author

Commented:
You can ping the servername and it will resolve the correct ip as this is static.
I use the local administrator account (Personal account on remote desktop) to view all folders via normally \\ServerIP however for some reason you can only resolve \\ServerName
I have not joined it to a domain, although i am planning to do so soon as i can then track easier who is accessing the Intranet.
I mentioned the use of IIS as we have many users who look back to the system via http:\\ServerIP but the recently installed EMEA active directory has enabled me to use DNS name to reolve the server over our WAN.

It is getting all confusing. why one side will work but not the other.
Jeff BeckhamEngineer
CERTIFIED EXPERT

Commented:
Static IP addresses don't imply that you have proper name resolution.  Having static IP addresses just mean that they won't change.

Can you map a drive to a share on the server by both server name and IP?  Try to do so by specifying the user account and password on the remote box.  Open up a command prompt window and try:

   net use z: \\<server_name>\<share_name> /user:<server_name>\<user_name>

You'll then be prompted for a password for <server_name>\<user_name>.  Be sure to use a know good username on the remote system for this command.  If you're able to successully map the drive, unmap it by issuing:

   net use z: /d

Then, try mapping it again by IP address:

   net use z: \\<server_IP>\<share_name> /user:<server_IP>\<user_name>

I understand that trying to browse to \\<server_ip> doesn't prompt you for a username and password.  However, if this last command doesn't work perhaps it will at least give us some indication as to what's happening.
obliv2k3Business and IT Systems Engineer

Author

Commented:
Tryed your suggestion,

No Luck.
going by \\ServerName works as i have previously stated however going by \\ServerIP does not.
I've tryed today to change the IP to an alternate in an attempt to force a rebuild of its internal routing tables to no success. I have restored the ip back to the original so that my users can continue to use the IIS pages.

Is it possible that this may be causeing the problem?
a setting in IIS?
If so, how come its happened linke this as all was well before i ran the latest windows updates.
Engineer
CERTIFIED EXPERT
Commented:
Have you rebooting the server recently?  I don't think I received confirmation that the server has been rebooted.

If you can ping the server by hostname/netbios name and it resolves to the correct IP, then it tells me that you've got some level of name resolution working and the machines are able to talk to each other on the network.

If it doesn't divulge to much information, can you post the results of a ping to the server by hostname and by IP?  Also, if you could post a a tracert to the remote machine by hostname/netbios name might help as well.

Is all other connectivity to the machine working as expected?  Can you TS into the machine by IP and by hostname/netbios name?

Unless you're actually connecting to a URL (ie, http:\\ServerIP), IIS shouldn't be coming into play.  There are in fact configurations options in IIS that would allow you to connect to a server via hostname and not IP, but again this shouldn't matter unless your connecting to the server via IIS.

Did you note the updates that were recently installed?  We could look at those updates, although I'm unaware of any issues with recent updates that might have caused a problem like this.  You could also start rolling-back (uninstalling) the updates one-by-one to see if you can locate the culprit.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
obliv2k3Business and IT Systems Engineer

Author

Commented:
I've managed to solve the problem.
I removed Service Pack 1, allowed it to restart (again) and now all seems fine.

I may reapply the service pack in the future however i doubt it would be a good idea to do again for a while.. let it settle down.

I have accepted your answers jebeckham as you have been the most useful in this problem. hopefully it wont happen again.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.