[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 375
  • Last Modified:

Point to Point T1 with two Cisco Routers

Hello,

I am currently *trying* to configure a Cisco 2800 and a Cisco 1841 to route traffic on a new private T1 line.  The Cisco 2800 will be located at our central site, and the Cisco 1841 will be located at the remote site, the T1 is totally private and both routers have T1 Wic's.  Ideally, I would like all traffic from the remote site to wind up on our default gateway router on the central site.  Here is what I have

Central Site T1 Router:
Eth IP: 192.168.1.253 / 255.255.255.0
Serial IP: 192.168.10.2 / 255.255.255.252


Remote Site T1 Router:
Eth IP: 192.168.115.100 / 255.255.255.0
Serial IP:  192.168.10.1 / 255.255.255.252

The default gateway at the central site is 192.168.1.254.  Below is the config I have for both routers.  With this setup,  I can do a tracert from the remote site to 192.168.1.254 (the central default gateway)  and it gets to 192.168.10.2 and fails.  I'm not sure what else I need to do.  I think I may need to enable Rip or Eigrp, but I'm not sure what settings to use.



MAIN OFFICE ROUTER CONFIG


Building configuration...

Current configuration : 1957 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
ip domain name yourdomain.com
ip name-server 192.168.1.25
!
username cisco privilege 15 secret 5 $1$mVSH$m2itOJYsML/pGwr3rF1oD/
!
!
!
interface FastEthernet0/0
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ETH-LAN$
 ip address 192.168.1.253 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 service-module t1 clock source internal
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.115.0 255.255.255.0 192.168.10.1
!
ip http server
ip http authentication local
ip http timeout-policy idle 5 life 86400 requests 10000
!
!
control-plane
!
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco".

Please change these publicly known initial credentials using SDM or the IOS CLI.
Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use.

For more information about SDM please follow the instructions in the QUICK START
GUIDE for your router or go to http://www.cisco.com/go/sdm 
-----------------------------------------------------------------------
^C
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end



**************************************************************


BRANCH OFFICE ROUTER CONFIG



Building configuration...-------------------------

Current configuration : 1953 bytes                                  
!
version 12.4ne con 0    
service timestamps debug datetime msecx 0          
line vty 0 4            
service timestamps log datetime msec  
 login local            
 transpo
no service password-encryption      
line vty 5 15        
!
hostname yourname 15              
!
boot-start-marker        
 transp
boot-end-marker              
!
logging buffered 51200 warnings0 1000                        
!
no aaa new-modelname#show run  
!
resource policyding configurat
!n
mmi polling-interval 60    

Current configura
no mmi auto-configure                    
no mmi pvc
version 1
mmi snmp-timeout 180ce timestamps debug
ip subnet-zero              
ip cef      
!
!
no ip dhcp use vrf connectedtetime msec                
!
!
!
interface FastEthernet0/0  
!
no aaa new-model  
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$subnet-zero              
!
!
ip cef      
!
!
ip
 ip address 192.168.115.100 255.255.255.0              
ip name-server 192.168.1.2
 duplex auto            
 speed autoame cisco p
!v
interface FastEthernet0/1m2itOJYsML/pGwr3rF1oD/  
 no ip address              
 shutdown        
 duplex auto  
!
!
!
 speed autoastEthernet
!0
interface Serial0/0/0  
 description $ETH
 ip address 192.168.10.1 255.255.255.252                                        
 encapsulation pppdress 192.168.1.25
 service-module t1 clock source internal            
 duplex auto            
 
!e
ip classless    
!
int
ip route 0.0.0.0 0.0.0.0 192.168.10.2        
Replace <myuser> and <mypassword> with the username and password you want to use
.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
end


*******************************************************************************

Again, a tracert from a PC on the remote site goes to 192.168.115.100, then to 192.168.10.2, then fails.  For some reason, it's not taking the extra hop to 192.168.1.254.  Please Advise.

Thanks Alot!
0
jgarrett115
Asked:
jgarrett115
1 Solution
 
simkoCommented:
you canot use rip because it is a class full routing protocol, i prefer ospf
you have to start ospf on both routers (config)>router ofpf #(some number >1)
(config-router)>network <network number of serial> <wildcard> area 0
(config-router)>network <network number of ethernet> <wildcard> area 0

this is the minimal ospf configuration you can do
regards
R.
0
 
kfullartonCommented:
Sounds like the problem is on 192.168.1.254.  Is there a route on this box for the 192.168.115.0/24 network?  It would look something like this:

ip route 192.168.115.0 255.255.255.0 192.168.1.253

Hope that helps...
0
 
jgarrett115Author Commented:
Thanks Alot!!  Putting that route in my central router fixed it right up!!
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now