Suddenly unable to change file/folder names

This happened quite suddenly this morning.  I noticed that a file was saved without an extension and I went to type it in.  I clicked on the file name in a finder window and I typed the extension.  Mac came up with the usual "do you really want to add this extension?"  and I had second thoughts.  I clicked "no" and then I was unable to change the name on any file or folder.  

When I click on the file name to change it, the usual blue highlighting appears and my mouse changes to a cursor.  I can put the cursor into the file name, but cannot type anything or move the cursor with my arrow/home/end keys.  

I am also unable to change the file name in the "get info" panel.

Any help would be greatly appreciated.

Thank you!

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Turn off file sharing.
getticaAuthor Commented:
File sharing is off and has been off both before and after this problem started.
You didn't say if you were running OS 9 or OS X. If you are in OS 9, you might accidentally have turned on Simple Finder. If you turn it off, that should solve your problem.

Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

If you are in OS X, here are the instructions for turning off Simple Finder:
getticaAuthor Commented:
I am in OS X 10.4.  I am opperating on an administrator account and thus cannot have any restrictions on my account.
Okay. Have you tried running "repair permissions" from Disk Utility?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
getticaAuthor Commented:
That worked.  Any idea how/why they got messed up in the first place?  
No idea. But the general rule is that you should always run "repair permissions" after installing system updates.
getticaAuthor Commented:
Great.  Thanks for the tip.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple OS

From novice to tech pro — start learning today.