CRM reports Page not found error with web client

I have a win2k server with sql and crm 3.0 installed. Everything works perfect except I can not run reports remotly through the web client. I am getting a page can not be displayed when running reports.
I firewall using ISA 2000 and have published the crm webserver and sql server.
Locally it works fine so it appears I have an error in the ISA publishing.
normkokesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ck_damuCommented:
Even I am having the same problem.

This is what is happening at my end.

if i give
http://IP Address/ReportServer?/PRONTO+SOLUTIONS+LLC_MSCRM/Account+Overview
its working.

if i give
http://MachineName/ReportServer?/PRONTO+SOLUTIONS+LLC_MSCRM/Account+Overview
its not working.

What i would assume is Server is not able to resolve the machine name though it is able to resolve the IP Address.
Again I would assume that there should be a SRV Record in a DNS to accomplish this.
Though iam not sure, May be Network admin can help you out.

I am working on it will let you know if i get something.
Damu
0
normkokesAuthor Commented:
OK I have found the solution.
The problem is the URL for the CRMreportserver is specified as a local machine name. Locally the reports work fine however remotly the system is trying to access a machine name that is non accessable.
If you look at the status bar when attempting to run a report remotly you will notice the URL starts out with http://crmmachine/
The correct URL should be http://crm.domainname.com/ or something like that.

The easy fix is to change the following:
Regedit the following key HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\MSCRM
edit the SQLserverurl to specify the internet address.
next edit the publish.config file which is located in the Microsoft CRM\reports directory. Do a search for the URL server name and replace with the internet address name.

A reboot is required so the new registry key load but it will work fine after that
0
DarthModCommented:
PAQed with points refunded (50)

DarthMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Enterprise Software

From novice to tech pro — start learning today.