5.7.1 Error on SMTP messages

I'm getting some messages bounced back from a few recipients.  Here is what the receipt says:

 There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <mail.company-name.com #5.5.0 smtp;553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)>

I recently added a PTR record to my mail server because email to AOL and Optimum Online were being delayed and bounced.

When I go to DNS reports, everything passes but i get a warning that I think might be related to this issue.  It reads:

WARNING: One or more of your mail servers is claiming to be a host other than what it really is (the SMTP greeting should be a 3-digit code, followed by a space or a dash, then the host name). This probably won't cause any harm, but is a technical violation of RFC821 4.3 (and RFC2821 4.3.1). Note that the hostname given in the SMTP greeting should have an A record pointing back to the same server.

mail.company-name.com claims to be invalid hostname '*******************************************************************
   220 ***************************************************************

Here is the background information:

I'm running MS Exchange Server 2003 which is also the domain controller running AD.
The external domain is: company-name.com but the internal domain name is: company-name-location.com
The internal name of the server is: apollo.company-name-location.com

The MX record points to an external IP address as mail.company-name.com

My SMTP virtual server has the masquerade domain and the FQDN as mail.company-name.com

Any help or assistance is greatly appreciated in advance.
cgizziAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
You have a PIX.
Disable the Fixup SMTP option in the Pix and that will stop a lot of the problems.

http://support.microsoft.com/default.aspx?kbid=320027

Once you have got that changed, make sure that your server is announcing itself correctly, and that the reverse DNS matches what the server announces itself as.

http://www.amset.info/exchange/dnsconfig.asp

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cgizziAuthor Commented:
Well, I do have the server behind a PIX Firewall but I don't think Fixup on SMTP is enabled.  I don't see that line when I show the config.

but I did turn off esmtp inspection just in case they are the same thing.

And on the second suggestion, the DNS lookup works... and I know that its set to the right value of mail.company-name.com

Hopefully, your first suggestion works.

SembeeCommented:
The
*******************************************************************
   220 ***************************************************************

Is classic PIX with fixup SMTP.
If you have a PIX with version 7.0 of the software it might be called something else. I haven't seen a 7.0 PIX yet so cannot be sure what they changed.

Simon.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.