Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 327
  • Last Modified:

I'm running into a 4GB limit on my external hard drive.

When I try to copy a 10 GB file to my 100 GB external hard drive - I get a "no space left on device" error after
4GB's have been copied (I've heard of this limit before - not sure if it's a device/partition limit or  what).

There's plenty of free space (50 GB left).

Should I reformat the device.  Why am I getting this problem and what do I need to do to be able
to copy the 10GB file.

Please elaborate.

Thanks
0
booksplus
Asked:
booksplus
  • 2
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
You're getting this problem because FAT32 supports a maximum of 4 GB files.  Convert the drive to NTFS either by using the CONVERT command or by reformatting the drive with NTFS.  NTFS has no practical file size limit.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Most likely, this would be the most appropriate command for YOU to convert the drive to NTFS.

CONVERT X: /FS:NTFS /X /NoSecurity
0
 
booksplusAuthor Commented:
Thanks - I'll award points.

One more question -
My home PC is FAT32 XP Home.   Will I be able to use the NTFS external drive at home.
0
 
CaseybeaCommented:
Yes, any drive (internal or external) formatted as NTFS will be able to be readable/writeable by any version of Windows XP (Home, Professional).

Also as a personal recommendation: I do not care for the "convert" utility.   My preference is to save off the files (if any), and re-FORMAT the drive as NTFS.   Then you're good to go.    My $0.02
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now