ado.net not listed in datasource

Hi I need to connect to an XML file as a datasource for a crystal report.. But ADO.net is not listed in the create new connection lists..

using Crystal 10.

any thoughts how i can add this in?

thanks
huziyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dylanyeeCommented:
When the time that you install CR10, did you check the ADO.NET in the datasource option? Try put in your CR installation disk again and modify CR10's installation.

dylan
0
mlmccCommented:
That would make sense?  Does your machine have the .Net framework installed?

mlmcc

0
huziyAuthor Commented:
I have popped the Crystal disk in to ammend the install but it doesnt give me the option of ADO.NET under Data Access???
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

huziyAuthor Commented:
.net 1.1 is install on this system
0
dylanyeeCommented:
strange... what is your windows version? could you try download & install the MDAC 2.8 and retry the CR installation?

http://www.microsoft.com/downloads/details.aspx?DisplayLang=en&FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c

dylan
0
huziyAuthor Commented:
its running on server 2003 (setup as terminal server)

i can give that a go if you think it might help?
0
dylanyeeCommented:
Windows 2003 should come along with MDAC 2.8... it won't help sorry.
Win2003's OS is shipped with .net 1.1 by default. Are you installing another copy of .net 1.1 to it...?
Even if you uninstall and reinstall the entire CR it still didn't give you an option for ADO.NET?

dylan
0
dylanyeeCommented:
And... can you see ADO.NET if you install the CR to other machine?

dylan
0
huziyAuthor Commented:
tried installing on another server.. same problem

possibly have installed another version of 1.1 as this has come with a recent application..
0
huziyAuthor Commented:
if i load up a report that has previously used ADO.net and refresh the report data from the "report" menu

i get

failed to load database information. Details: The database DLL 'crdb_adoplus.dll' could not be loaded.
0
dylanyeeCommented:
0
dylanyeeCommented:
What version is your CR? the link above indicate that

Crdb_adoplus.dll is not included with the Standard and Professional editions of Crystal Reports 9, or with Crystal Enterprise 9

You have to download and apply the update
ftp://ftp.crystaldecisions.com/outgoing/EHF/Cr90dbexwin_en.zip

dylan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
huziyAuthor Commented:
i saw this although we are using Version 10 standard?
0
mlmccCommented:
Same for CR10 and XI.  You need developer edition or advanced

http://www.businessobjects.com/global/pdf/products//crystalreports/crxi_feat_ver_ed.pdf

mlmcc
0
huziyAuthor Commented:
many thanks...

downloaded trial of developer edition and it works fine!!

0
mlmccCommented:
Glad i could help

mlmcc
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.