allow anonymous remote access in DCOM - Service pack 2

I am using the following steps to change the settings for dcom.  The 'Edit Limits' button is greyed out.  I am logged in as a local admin and the firewall is disabled.
any ideas?



To allow anonymous remote access in DCOM:

1.From the Start menu, click Run and type Dcomcnfg.exe.

2.In Component Services, click Console root, click Component Services, click Computers, and then click My Computer. On the Action menu, click Properties.

3.In the My Computer Properties dialog box, on the COM Security tab, in the Access Permissions section, click Edit Limits.

4.In the Access Permissions dialog box, grant Anonymous Logon allow Remote Access.


thanks,
K
LVL 11
chadAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KenneniahCommented:
Most likely a security policy is enabled. Go to Start|Run and type secpol.msc
Expand Local Policies|Security Options
Look for DCOM:Machine Access Restrictions...........
If that is set, it does grey out the button in dcomcng.
Either set the security in the secpol.msc setting, or delete all accounts in the secpol setting, and then you should have access to the buttons in dcomcnfg.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chadAuthor Commented:
great thank you.  I did not have the chance to test this out.  We ran into onother issue that forced a re-installing xp.  
I did check the secpolicy that you mentioned and I did notice that there were accounts in there.  I have another xp sp2 machine that did not have any accounts there and I could access the limits pages.  So, I am guessing that your fix suggestion would work.

I appreciate it.
Thanks
K
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.