smtp and native Pop3 setup problems with exchange server 2003 500 POINTS.....

Helo experts,

I'm have just started a contract on a domain with 2 2003 DC's and a stand alone 2003 exchange server behind a sonic firewall.

Problem is that some one prior to me setup the mx record from their web domain host to point at the exchange server which caused 2 main problems.

1. They had many problems mostly due to ISP dropping connection and mail being redirected to the domain host mail servers. Therefore they had mail on the exchange and the mail host servers. I had the domain host to change the mx record back and currently have all the client setup via outlook pop3 mail.

2. I'm getting weird smtp errors in the App. log which I am going to post in a little bit when I get over there. It seems like they setup different smtp virtual servers and moved away from the MS defualt. I am not sure how to get rid of those and just use the MS defualt setup to route outgoing mail via DNS.


So to remedy situation 1 I install MapiLabs Native Pop3 connector on exchange box and setup a test client to try it out.
I'm not receiving any incoming mail and I know port 110 is open on the firewall because all the pop3 outlook client are recieving fine.

When I get there in about an hour I'm going to post the DNS error and the native pop3 log for review.
 
jscott1979Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jscott1979Author Commented:
Fixed Native POP3 problems but am still getting error and warning logs under event viewer --> Application.

Source: MSExchangeTransport
Category: SMTP Protocol
Event ID: 7002

This is an SMTP protocol warning log for virtual server ID 1, connection #68. The remote host "65.89.139.10", responded to the SMTP command "rcpt" with "450 4.7.1 <oem-sales@cablestogo.com>: Recipient address rejected: Policy Rejection: Greylisting in use. Please try again shortly.  ". The full command sent was "RCPT TO:<oem-sales@cablestogo.com>  ".  This may cause the connection to fail.
 
and

Source: MSExchangeTransport
Category: SMTP Protocol
Event ID: 7004

This is an SMTP protocol error log for virtual server ID 1, connection #62. The remote host "66.194.158.200", responded to the SMTP command "xexch50" with "504 Need to authenticate first  ". The full command sent was "XEXCH50 2488 3  ".  This will probably cause the connection to fail.

Whats causing this?
0
jscott1979Author Commented:
The outgoing mail is not working. How do I check if the smtp virtual server is configured correctly?
0
jscott1979Author Commented:
Is there no expert out there that can help? I guess I'm waisting my money on this site......I have this question and anther open hear in exchange and have recieved little help.

Should I be posting this question somewhere else or what?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SembeeCommented:
There is never a guarantee that you will always get an answer on this site. We are all volunteers and as such it depends on whether we have any spare time to look. I have been on client site for the last two days so haven't reviewed anything.

You need to find a solution that involves ditching the POP3 connector. POP3 connectors are evil things and should be avoided where possible.
The original problem that you outlined sounds like it was caused by duff DNS records and poor service from the ISP.

I would rip out all of the MX records for the domain, enter a SINGLE MX record for the domain pointing at the Exchange server only. That will stop email being delivered to any other servers and provide a single email flow. If the ISP is unable to provide a stable connection then ditch the ISP and get another one.

The error messages that you are seeing are fairly typical. The first one means what it says, they are using grey listing. Unfortunately the remote site has setup the grey listing incorrectly and are sending back a fatal failure inside of a temporary failure message. Not much you can do about that.

The second message is most often caused by a smart host being configured on the SMTP Virtual Server. The Exchange server thinks it is talking to another Exchange server, or the smart host requires authentication.
Remove the Smart host from the SMTP Virtual Server and use an SMTP Connector instead. If the ISP requires authentication when sending email then you can configure that on the SMTP connector.

http://www.amset.info/exchange/smtp-connector.asp

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
flyguybobCommented:
I concurr with Sembee.
Is the connection that you are on a DSL or Cable connection or is it a true connection to the net?  You may have to have your provider setup a PTR record and an SPF record for your Exchange server.

Dependent upon your ISP, you may have to configure an SMTP connector to use your ISP as an authenticated mail relay.  This is actually pretty easy to configure and works well for folks behind ISPs such as Comcast.  Sembee's site touches on that quite nicely.

I work a day job at a large client and usually only respond when a colleague takes a smoke break or during lunch...
0
jscott1979Author Commented:
Sorry guys, I know you are volunteers but I had another question posted in exchange with no comments for weeks and usually they are cleared up in days and was feeling kind of forgotten.

I set up the smtp connector how it describes to through the link Sembee and setup the smart host to point at the IP of their web host company mail server.

Everything seems to be working fine..........1 more question though

Do I need the Virtual SMTP server under->protocols->SMTP to be running?

 It seems to me that is not needed when you use the SMTP connector.

What do you guys think, should I leave it alone or can I stop it?
0
SembeeCommented:
The SMTP Connector is NOT a replacement for the SMTP Virtual Server. You have to leave the Default SMTP Virtual Server in place as it is used by the SMTP Connector.
Why would you want to stop it? What makes you think that it isn't used?

Simon.
0
flyguybobCommented:
If you are not sending mail, or don't have multiple servers in your environment, then no, it is not needed.  I had a client that disabled theirs to prevent all internet mail from routing (it's a long story, but it had to do with attachments).  Ultimately I convinced them to let it run and simply deny port 25 at their firewall.  With more than 1 server, or to send messages to the internet, you need it.
In your case, the SMTP Connector uses the Default Virtual SMTP server as its, well, Default SMTP Virtual server.

Not to be rude...but you may want to dig into the guts of Exchange.  This is a link with some great, and free, information:
Http://www.microsoft.com/exchange/library
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.