We help IT Professionals succeed at work.

FC4 fileserver, can see folders but can't open them

DexterJones
DexterJones asked
on
Medium Priority
385 Views
Last Modified: 2013-12-06
i am trying to setup a fileserver using fedora core 4 that will be accesible to my windows machine (workgroup environment). So far on my windows machine i can see the folders that i have created/shared but for whatever reason i can't seem to open them.
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2006
Commented:
you need to give perms to folder and in /etc/samba/smb.conf add this line to a share element
create mask = 0765
for example

[myshare]
   comment = Mary's and Fred's stuff
   path = /usr/somewhere/shared
   valid users = mary fred
   public = no
   writable = yes
   printable = no
   create mask = 0765

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
i tried what you said but i still cant open the said folder, below is my smb.conf

# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2006/03/22 15:51:27

# Global parameters
[global]
      server string = Samba Server
      interfaces = eth0
      username map = /etc/samba/smbusers
      log file = /var/log/samba/%m.log
      max log size = 50
      socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
      printcap name = /etc/printcap
      domain logons = Yes
      os level = 65
      preferred master = Yes
      domain master = Yes
      dns proxy = No
      wins support = Yes
      ldap ssl = no
      idmap uid = 16777216-33554431
      idmap gid = 16777216-33554431
      cups options = raw

[homes]
      comment = Home Directories
      path = /home
      read only = No
      create mask = 0664
      browseable = No

[printers]
      comment = All Printers
      path = /var/spool/samba
      printable = Yes
      browseable = No

[netlogon]
      path = /home/samba/netlogon
      guest ok = Yes

[profiles]
      path = /home/samba/profiles
      read only = No
      create mask = 0600
      directory mask = 0700
Artysystem administrator
Top Expert 2007

Commented:
Do you listen pablouruguay? He has clearly said to setup create mask to 0765.
you have create mask = 0664, 0600, even owner has no directory scan permission..
Artysystem administrator
Top Expert 2007
Commented:
Also that directories you have already created with such mask will be inaccessable until you manually setup +x flag.
Only newly created will be affected. Samba also need to be restarted and all connections reconnected.
Changing the create and directory masks is not necessary if the only intention of the user is to read the files already inside the directory. However, if you intend to make some directories writeable, those would be necessary.

Also, make sure that the directories you want accessible are both readable and executable (chmod +rx) in the system itself. If a directory is readable, users will be able to generate a list of the files inside this directory. Executability, then, allows navigation inside the directory.
chmod and chown so you are the owner and have permissions to read it, write to it and execute it (chmod 777).
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.