Lock up root accout

How do you change the settings so that 'root' account can ONLY be used/accessed on the node consol?
It shouldn't be allowed that anyone uses 'root' account to access the node from remote sites.
JohnLucaniaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

noondayCommented:
To disable remote login access for your root user, edit the /etc/security/user file. Specify False as the rlogin value on the entry for root.

Seems you have a lot of aix questions here...:)
0
JohnLucaniaAuthor Commented:
I view:

/etc/security/user

default:
        admin = false
        login = true
        su = true
        daemon = true
        rlogin = true   ========> do you mean modifying this to 'False'?
        sugroups = ALL
        admgroups =
        ttys = ALL
        auth1 = SYSTEM
        auth2 = NONE
        tpath = nosak
        umask = 022
        expires = 0
        SYSTEM = "compat"
        logintimes =
        pwdwarntime = 0
        account_locked = false
        loginretries = 0
        histexpire = 0
        histsize = 0
        minage = 0
        maxage = 0
        maxexpired = -1
        minalpha = 0
        minother = 0
        minlen = 0
        mindiff = 0
        maxrepeats = 8
        dictionlist =
        pwdchecks =

root:
        admin = true
        SYSTEM = "compat"
        registry = files
        loginretries = 0
        account_locked = false
0
noondayCommented:
Not this one. This is under the stanza of "default" which applies to every user id. What you want to is to add "rlogin = false" into the stanza of root since you don't have this entry in it.

So it shoud look like this:

.
.
.
root:
        admin = true
        SYSTEM = "compat"
        registry = files
        loginretries = 0
        account_locked = false
        rlogin = false
.
.
.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

tel2Commented:
It's been years, but I think disabling rlogins will not disable "any" TTY logins.  I think you set "TTY" to "/dev/tty0" or something.  Only necessary if there are TTYs apart from tty0, of course.
0
tel2Commented:
Sorry - that should have been:
  ttys = /dev/tty0
I think you can also do this via "smit security".
0
Sandy_itCommented:
This blocks users from telnet/rlogin:
# smitty
  ==> Security & Users
    ==> Users
      ==> Change / Show Characteristics of a User
        ==> User NAME                [root]
          ==> User can LOGIN REMOTELY                [false]

If you need to block logins from other serial terminals, you'll have to edit the "Valid TTYs" field from "ALL" to the name of your console device.

Rgds
-Sandy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.