Font Problems with Oracle App Server 10g


I am trying to setup an Oracle 10g Application server.  I have a report up and running, but the bar code font I have installed doesn't appear to be working.

The server is running Red Hat Enterprise Linux 4.  I followed the instructions from Red Hat to install the bar code fonts and I can verify the server can see them (if I open gedit, I can pick the bar code fonts from the list).  Even with this, when I run a report I do not see the bar code.  The fonts are true type fonts and I am wondering if for Linux they have to be Type1?!?

The steps I followed to install the new fonts (per Red Hat) were:

1. Create the /usr/share/fonts/local/  directory (if it doesn't already exist):

mkdir /usr/share/fonts/local/

2. Copy the new font file into /usr/share/fonts/local/

3. Update the font information by issuing the following commands (note that, due to formatting restrictions, the following commands may appear on more than one line; in use, each command should be entered on a single line):

ttmkfdir -d /usr/share/fonts/local/ -o /usr/share/fonts/local/fonts.scale

mkfontdir /usr/share/fonts/local/

4. If you had to create /usr/share/fonts/local/, you must then add it to the X font server (xfs) path:

chkfontpath --add /usr/share/fonts/local/

As I said above...this seemed to work.  I do not know what to try next.  The old report server was running on Windows with the same fonts installed and worked just fine.

If there is anything anyone can think of...please help!!!  If you would like more info...I would be happy to provide it!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

It's not just installing the font. For reports you also need to configure
- uiprint.txt
- install the font's AFM file
- make font aliasing in uifont.ali

If you have access to metalink you will find note 62038.1 describing the steps to take.

But Oracle provides a much easier way: Have a look at this one here:

It uses JavaBeans, and no additional fonts are needed on the server.

Check it out....



Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kfrankovichAuthor Commented:

Thank you for help...I will check this out!

The only thing I have a question on then is True Type Fonts.  They don't come with an AFM file...there is only a single TTF file.  Can these work or do I absolutely need Type1 Postscript fonts?

Thank you.
I'm not that font specialist, but there's a tool named ttf2afm. It comes with another tool named pdftex. Google for it....

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.