Second Exchange Server not receiving emails

I had a single existing Exchange 2003 server to which I have added a second on the same domain.  My goal is to move about half of the mailboxes to the second server, but I can't seem to get the second server to receive any emails.  I have added some test accounts to the second server, and they show up in Active Directory and Exchange System Manager on the first server.  I can send emails to accounts outside our domain from the accounts on the second server, but I can't receive any from the first exchange or outside our domain or send any to the first exchange.  How can I troubleshoot this problem?
RobocoxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
Turn on message tracking on both servers to start with. That will show you what Exchange is doing with the message.

The most common cause of emails not flowing between the servers is a smart host configured directly on the Default SMTP VS. If you need to use a smart host to get the emails to flow out, then use an SMTP Connector instead.

http://www.amset.info/exchange/smtp-connector.asp

As an aside, do you use OWA?
If so, with your current configuration you will need to expose both servers to the Internet for OWA to work. Furthermore the users will need to know which server their mailbox is on and know the direct URL for it. The automatic redirect from one server to the other will only work if the server's real name is resolvable on the Internet.
If you are a heavy OWA user then you need to look at purchasing a third Exchange server - standard edition will do, and configuring it as a frontend. That way you can have a single point of entry to email.

Simon.
0
RobocoxAuthor Commented:
Message tracking is on, and I just realized I left a rather large piece of the puzzle out.  I am very sorry!  Both of the Exchange 2003 servers are actually back-end servers with a Linux box serving as the front-end MX.  As I tracked a message on the second server, it processes it fine, but doesn't recognize that it is a local delivery.  It sends the email to our Linux MX, and it gets into a mail forwarding loop with the Exchange Server.  Why do they not know where to send a local email?  A similar thing happens from off-site.

I do think it has something to do with the connections properties, either bridgeheads, smart hosts or address space.  What should the bridgeheads and smart hosts look like?  Right now, the smart host field points to MX's IP and the bridgehead lists the first server.  All three servers are listed in the address space with equal cost.  The Linux MX is doing its job of sending the mail to the first server, but the first server does not seem to know what to do with it then other than send it back to MX.  Help!

OWA does not seem to be a problem on-site, but I will check it off-site to see what happens.  Thanks for that bit of advice.
0
SembeeCommented:
Is the smart host on the SMTP VS directly?

ESM, Servers, <your server>, Protocols, SMTP. Right click on the SMTP VS and choose Properties. Click on the tab Delivery and then Advanced. If smart host is completed in there, remove it and replace it with an SMTP Connector. The smart host on the SMTP VS causes ALL email, even inter-server email to be sent to the smart host, which probably cannot deal with the message.

The SMTP Connector should have a smart host configured as your Linux box, with both the Exchange servers listed as bridgeheads.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

RobocoxAuthor Commented:
Our smart host is in there, or at least the IP to the MX box.  When you say "remove it and replace it with an SMTP Connector."  What would that look like?  Something like server1.domain.com or an IP or is it something else?
0
SembeeCommented:
An SMTP Connector uses the same information that you have on the SMTP Virtual Server.
You have to remove the smart host from there, because it is stopping the message flow.
http://www.amset.info/exchange/smtp-connector.asp

Simon.
0
RobocoxAuthor Commented:
I took the smart host out, and we are sooo close.  I can send every direction (off-site to on, on-site to off and from first server to second) except from the second server to the first.  What setting am I missing?
0
RobocoxAuthor Commented:
I got it...I was overlooking an easy setting...restarting the second server smtp connector...THANK YOU!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.