RPC over HTTPS is not working

This is to follow up with my previous question here:
http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21773500.html

i reinstalled a new server and used a different domain name. i still got the same problem. i am not able to connect to it. i think the problem may be my firewall. i have netscreen 5xt  but i am not sure how to configure or allow port 6001-6004 for RPC over HTTPS. is this the problem here?
hiephoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
You don't do anything to your firewall other than allow port 443 through. No other ports need to be opened as that is the point of the feature.
Furthermore you should be trying to get this to work inside the network first - so the firewall configuration should be playing no part in any problems with RPC over HTTPS. Get it work inside first, then go outside.

Simon.
0
hiephoAuthor Commented:
thanks for the firewall tips, i have removed the ports that i just opened.

i got the new test server i just built working now both internally and externally. i am not sure what i did other than going over and over all the steps and make sure they are correct. one interesting thing is this:

in client outlook the setting is kind of not right but for some reason it still works.
E-mail accounts > Exchange Server Settings > Microsoft Exchange Server: initial set up i had mail.mydomain.com but once it is connected it changed to servername.mydomain.com instead.

as you can see servername.mydomain.com is not qualified domain but it works for some reason. is this normal? is my RPC over HTTPS working right yet or if it works then it's ok to leave it?
0
SembeeCommented:
The initial Outlook configuration will also correct to the server's real name. That is by design and is to be expected.
What I usually suggest is that Outlook is configured in the regular way and verified that it is working correctly. Then add the RPC over HTTPS settings separately. That allows you to rule out a problem with the account or the basic setup.

To verify that RPC over HTTPS is working, add the entries in to Outlook, then close Outlook completely.
Click Start, Run and type

outlook.exe /rpcdiag

and press enter.
This will show you what Outlook is doing. If it shows the connection protocol as https then it is working. If it shows it as tcp/ip then it isn't working correctly.
Take a look at my web site here for a screenshot.
http://www.amset.info/exchange/rpc-http-diag.asp

Simon.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

hiephoAuthor Commented:
Outlook works normally in regular way before i attempted RPC.

i have done outlook.exe /rpcdiag and it did say HTTPS connection.

i guess i need to figure out why the real server is not working just like the one i just built.


0
SembeeCommented:
If RPCDIAG shows https then the feature is working correctly. You will need to compare the configuration of the two machines. If they are both in the same domain, then the registry entries should be different only in the name of the Exchange server - everything else should be the same.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hiephoAuthor Commented:
i can't believe it. it was a simple configuration that solve the problem. i don't need to build another test machine now. it works now.  

after i have read through this post here that had the same problem as mine
http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21774531.html?qid=21774531

in IIS > rpc > i need to have it set to "Scripts and Executables" instead of just "Scripts"

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.