Why is the colour mixed up when I try to play videos with my new graphics card?

My old graphics card stopped working so I replaced it with a inno3d geforce fx 5500 (was also an nvidia geforce 4 before). The new graphics card is working fine, except for when I play any videos. The colour is all messed up. It is as though the contrast, brightness, etc are not set right and they cannot be corrected by adjusting the values in the video player program. The problems are apparent in both media and realplayer (and I assume any other). The colour is otherwise completely normal everywhere except for on the video playing. The operating system is XP. Any thoughts on what I can do to sort it out? Something I need to download? Thanks a lot!
UJAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
can your video player program be reconfigured / retested?  Also, you may want to go to DISPLAY PROPERTIES, and change the color settings to TRUE-COLOR (highest selection possible)
0
UJAuthor Commented:
The problem is universal for any video player program (windows media, realplayer, winDVD) that I have tried so far. The colour is set to high 32 bit in display settings if thats what you mean and reducing it to 16 bit does not help either. As far as I know, there is not the option of reconfiguring or retesting the media players, but if you know of any way how, I will try it.

Thanks for your effort.  
0
Irwin SantosComputer Integration SpecialistCommented:
http://www.inno3d.com/support/download_inno3d.html
The latest drivers are at that link. Download and install.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
UJAuthor Commented:
Haha, yeah that fixed it, thought they had already been updated but I guess not. Simple fix i guess, cheers for your help mate!
0
Irwin SantosComputer Integration SpecialistCommented:
cool. thank!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Graphics Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.