an smtp protocol error occured

Hi All,

I have a problem about sending mail: I have a Exchange 2000 Server/ windows 2000 server. It almost complete except for messages to yahoo.com and a few other domains sit in queue in retry mode.  If I check the properties of the queue it says that An SMTP protocol error occurred.  I send mail to yahoo.com, then i receive mail Delivery Status Notification (Delay) and mail undelivery from postmaster@mydomain. I check yahoo mail and not receive mail from my domain.  I'm at a loss!  Help me please!!
Thank in advance
cloudycunAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gdekhayserCommented:
Yahoo simply doesn't like your server.  

Check the basics:  
1) Do you have a proper reverse DNS entry (PTR) for your server's IP, meaning the IP it presents itself to the world as?
2) Are you on an RBL- check and 'spam database lookup' at http://www.dnsstuff.com and put in the address mentioned in step #1.

Also- you probably also have problems sending to AOL, I'd be surprised if that wasn't the case.

Glenn
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SembeeCommented:
If you are on a DSL connection or dynamic IP address, then you will probably have email delivery problems. You will need to use an SMTP Connector to route through your email through your ISPs SMTP Server.

Otherwise check that everything matches - DNS, reverse DNS and what the server announces itself as.
http://www.amset.info/exchange/dnsconfig.asp

Finally I have seen these sorts of problems caused by firewalls. If you have a firewall (what am I saying cos you will have a firewall), check whether it has any kind of SMTP scanning features and if so, disable them.

Simon.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.