Extremely urgent ! Unable to remove "read-only" mark from inetpub area.

Hi there..

Suddenly something happened yesterday (i have no clue what) which resulted to access-restrictions in write-permission to/within the inetpub folder.. (it's placed on the D-drive btw).

I have a ASP.NET/VB.NET application (D:\inetpub\wwwroot\persona\), and are now unable to do any work at all due to this annoying read-only problem.

PS! it's not marked "fully" read-only, which means it's read-only with a mark in it, but "grayed out" in the background of the checkbox.

I have tried running "attrib -r inetpub" but that didn't help either.. checked attrib no the inetpub folder by using "attrib inetpub" and it shows no Read-Only mark on it (through dos)..

When i remove the "read only check" and press "accept", and goes back in to check, it's still read-only marked. I have even tried to reboot the server for this to go away, but doesn't help.

Hmm.. any idea how i can check this any further, and what might be wrong here ?

Best regards
Terje.
Kripos56Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Giuseppe 'Pino' De FrancescoSnr. Solutions ArchitectCommented:
Hiya,

from the IIS Manager, open your site properties, go to the Home Directory tab and mark the Write check-box. That's shoud be all.

Cheers
Pino
Kripos56Author Commented:
Hi there gdefancesco :)

Well.. been through that solution now.. and it seems "write" (and everything else) is marked already..

What's weird.. is that it seems like all the "folders" are read-only. The read-only is partly checked when looking at all folders under inetpub, but when looking at the files... none of them are put read-only at all..

Some information about system and developmentenvironment :

Server : Windows 2003
Webserver : IIS 6.0

Dev. language : VB.NET / ASP.NET
Dev. application : Visual Studio .NET 2003.

Solution file is in same folder as rest of the web app.

Any other ideas ?

Terje.
Giuseppe 'Pino' De FrancescoSnr. Solutions ArchitectCommented:
That's weird,

Go in the Advanced permissions (of your folder): can you post here what you read there?
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

Kripos56Author Commented:
Hi there.. have checked that out.. see information both from Advanced permissions and my web.config file :

* All accessrights below have :  "Folder, Subfolders and Files" Permission.

Read & Execute :
Anonymous Logon
Users (COMPUTERNAME\Users

Full Control (except take ownership) :
Network Service
LOCAL SERVICE
ASP.NET Machine Account (MACHINENAME\ASPNET)

Full Control :
TNY010 (DOMAIN\TNY010) (which is me..)
Administrators (COMPUTERNAME\Administrators)
Creator owner
System

Owners are :
Administrator(COMPUTERNAME\Administrator
Administrators(COMPUTERNAME\Administrators)





WEBCONFIG FILE :

<?xml version="1.0"?>
<configuration>
      <system.web>
      <httpHandlers>
     <add verb="GET" path="FtbWebResource.axd" type="FreeTextBoxControls.AssemblyResourceHandler, FreeTextBox" />
    </httpHandlers>
            <identity impersonate="true"/>
            <authentication mode="Windows">
            </authentication>
            <customErrors mode="Off"/>
            <httpRuntime maxRequestLength="20000"/>
            <compilation debug="true">
                  <assemblies>
                        <add assembly="ProposionN2N, Version=2.0.0.0, Culture=neutral, PublicKeyToken=47A476656D73EED4"/>
                        <add assembly="Proposion.Licensing, Version=2.5.0.0, Culture=neutral, PublicKeyToken=47A476656D73EED4"/>
                        <add assembly="Proposion.N2N.Designers, Version=2.0.0.0, Culture=neutral, PublicKeyToken=47A476656D73EED4"/>
                  </assemblies>
            </compilation>
      </system.web>
</configuration>
Kripos56Author Commented:
ah.. just a tiny correction : COMPUTERNAME is the same as MACHINENAME ofcourse :) hehe.

btw : increased the points to 500 due to the difficulty..

Terje.
Giuseppe 'Pino' De FrancescoSnr. Solutions ArchitectCommented:
Ok,
but what user is in the Directory Security tab ->Edit ->Authentication method ??
Kripos56Author Commented:
ah.. understand..

1) Enable Anonymous Access is UN-checked
2) Integrated Windows Authentication is checked
3) The three other checkboxes are UN-checked

On the IP-address tab, all computers are "Granted for access".

By the last testing i've done, this seems more like a "windows security" issue, rather than IIS-security.. agreed ?
Not sure yet though...

More information :
Tried to edit a file though notepad (which means.. no Visual studio .NET 2003 interferrence) both from my pc and a co-workers pc.. didn't work.. saying i have no access to write to this folder..

BUT... one of the domain-admins here, successfully modified, and saved the file..

Terje.
Giuseppe 'Pino' De FrancescoSnr. Solutions ArchitectCommented:
Ok, your web service needs authentications against the AD, so I think that you shoud grant to "DOMAIN\Domain Users" permission to Modify, Read, Execute, List folder content, Write, and be sure that the permission will be applied also to child object, this should solve your problem.

Cheers
Pino

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kripos56Author Commented:
Hi there Pino :)

It seems it was a share on InetPub which was making all the trouble, since i connected to the solution (VS2003) with this share.. Everything is sorted out now :)

Thanx for all your help!!.. made me going the right direction..

Terje.
Giuseppe 'Pino' De FrancescoSnr. Solutions ArchitectCommented:
Glad to help

Cheers
Pino
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.