• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1636
  • Last Modified:

GPO for "Files Not Cached" not working ?? -- need help quickly please -- 500 pts

I have a domain called BARNESNET.  My users are using roaming profiles and their desktop and "my documents" folders are being redirected to a server share.  A few users have laptops and when they are disconnected to the server share, their "my documents" and "desktop" files need to be made available offline.  I have moved my users MS Outlook data from the "local settings" folder to a folder under "my documents" called "outlook data" for several reasons.  

At the domain level, I have a GPO policy that defines some default stuff for everyone.  In that policy, I have put a custom list of file extensions to exclude when synching:

barnes_default_policy > Admin Templates > Network > Offline Files > Files Not Cached

Most notably, I have removed *.pst, and *.mdb from the default list because I want MS Outlook and MS Access files to be made available offline.

I have made sure that the GPO security settings are applying to "domain computers" and to "barnes_employees" which is the computer group and user group that I want this setting to apply to.

I have done a RSoP on a user and computer and my "files not cached" setting appears correctly.  It is only set in the "barnes_default_policy" so there is not any inheritance problems that I can see.  All should be well.

However, when I actually log into said computer, there are two things that make me think the GPO isn't actually being applied to the computer.

1) When I look at the computer policy by using gpedit.msc, I don't see my "files not cached" setting.  However, I am not that familiar with GPOs, so maybe the policy the local computer policy that gpedit.msc is showing me is not the same policy that is in effect for my domain controlled user.

2)  When I logoff, I still get warning messages about 'pst' and 'mdb' files not being able to be made available offline.

So, my questions are:

1)  How can I know if my GPO from the domain is actually being applied to the computer when I am logged onto it.

2)  How can I know for sure that the files are actually being made available offline.  Keep in mind that I am doing this at a remote location, so I can't just unplug the machine and see if Outlook works.  It has to be something I can do without physically touching the machine.  

3)  How can I get rid of the "files not able to be made available offline" error messages.

Points go to that person who helps quickly BUT also sticks with me to the end of the problem.  Points WILL BE AWARDED when the question is satisfactorily answered.

Thanks.

1
edward47150
Asked:
edward47150
  • 2
1 Solution
 
NJComputerNetworksCommented:
1)  How can I know if my GPO from the domain is actually being applied to the computer when I am logged onto it

The Best way I know of is using the Group Policy Management utility.  It can be downloaded here: http://www.microsoft.com/downloads/details.aspx?FamilyID=0a6d4c24-8cbd-4b35-9272-dd3cbfc81887&displaylang=en  You can create a report using this tool to show what GPO's are being applied.

2)  How can I know for sure that the files are actually being made available offline.  Keep in mind that I am doing this at a remote location, so I can't just unplug the machine and see if Outlook works.  It has to be something I can do without physically touching the machine.  

There is a section called "Troubleshooting Files and Folders Management" in this document for answering question 2:  
http://www.microsoft.com/technet/prodtechnol/winxppro/reskit/c06621675.mspx


3)  How can I get rid of the "files not able to be made available offline" error messages.  Do not try to replicate PST or MDB files.  These files can not be managed properly using offline folders...

Making Files Available Offline
Files are cached either automatically or manually to the computer that requests them. Automatic caching occurs when a specific file in a folder is opened, but only if the server indicates that the contents of the share must be automatically cached. Automatically cached files are marked as Temporarily Available Offline in the Offline Files folder because they can be removed from the cache as the cache fills up. There is no guarantee that an automatically cached file will be available when offline.

Files are manually cached when a computer specifically requests, or pins, a particular file or folder on the network to be made available offline. You pin a file or folder by selecting the file or folder and, on the File menu, selecting Make Available Offline. Manually cached files are marked as Always available offline in the Offline Files folder.

In Windows 2000 and Windows XP Professional, the Manual Caching for Documents setting is enabled by default when a folder is shared. To change the setting so that documents in the shared folder are automatically cached, right-click the folder, click Properties, click the Sharing tab, and then click Caching. In the Settings box, select Automatic Caching of Documents. You can also disable caching.

Note You can manually pin files and folders that are configured for automatic caching.

By default, the following file types are not cached:

*.slm; *.mdb; *.ldb; *.mdw; *.mde; *.pst; *.db?

You can override the default settings by using the Files not cached Group Policy setting. Any file types that you specify in the Group Policy setting override the default settings. For example, if you specify that only .txt files cannot be cached, all other file types are available for caching.

source: http://www.microsoft.com/technet/prodtechnol/winxppro/reskit/c06621675.mspx

0
 
NJComputerNetworksCommented:
Additional info about

By default, the following file types are not cached:

*.slm; *.mdb; *.ldb; *.mdw; *.mde; *.pst; *.db?


http://www.jsifaq.com/subG/TIP3100/rh3163.htm

http://support.microsoft.com/?kbid=252509

0
 
jeffrashCommented:
You cannot make database files available offline, and PST files are database files. There is no way around it.

1.      Use the RSOP tool in the GPMC

2.      First…

a.      Open Windows Explorer
b.      Click on TOOLS
c.      Click on FOLDER OPTIONS
d.      Click on the OFFLINE FILES tab
e.      Click on VIEW FILES at the bottom of that tab

3.      The only way to do that is to stop putting database files in the "My Documents" folder or any other folder that you make available  offline
0
 
edward47150Author Commented:
jeffrash,

You information is inaccurate.  You can indead make these files available offline using the method described in my question, or if not using a DC, then chaning the local computer policy.

NJComputerNetworks,

Thanks for the response.  Interestingly enough, when I came back to work on this computer after the weekend, it appeared that my domain GPO was being applied correctly.  I used the tool you recommended to check the computers RSoP for confirmation and my file errors went away.

PST and MDB files are now being made available offline and synchronized appropriately.  

Thanks for the help.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now