Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cisco HSRP

Posted on 2006-03-23
6
Medium Priority
?
1,074 Views
Last Modified: 2010-05-18
Is it possible to configure 2 cisco routers to run HSRP over WAN links (located at 2 distant cities) so that redundancy of the routers can be established?
0
Comment
Question by:tozden
6 Comments
 
LVL 19

Expert Comment

by:CoccoBill
ID: 16269182
I believe that's exactly what it's meant for?

http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/cs009.htm
0
 

Author Comment

by:tozden
ID: 16269634
You can refer the following diagram: HOST  uses Redundant R1 (active) router to access internet and switch to the Redundant R2 in case of a problem in R1.

Host                   INTERNET                                        INTERNET
   |                        |                                                        |
 Ethernet-----Redundant R1 (active)                 Redundant R2 (stndby)
   |                                                                                  |
   |---WAN Router1 ------------------------WAN Router2-----Ethernet



As far as I understood; HSRP is a redundancy mechanishm designed for local LAN's (e.g. ethernet) based on the ARP replies..

My aim is to understand whether such a solution is possible by use of HSRP (routers located in distant cities); actually I do not want to implement this as as solution.
0
 
LVL 14

Expert Comment

by:ECNSSMT
ID: 16269881
The heartbeat between the two routers would have to be unobstructed; and If I recall correctly its a layer 2 frame.  So, I suppose, if there were no intermediary routers, it is possible.  The only thing would be that, it may not be practical depending on your subnet scheme.  With HSRP you are providing a path to a virtual router (IP Address/virtual gateway), which the all network devices have to use to egress your network into the internet.  If the two routers were on the same subnet it would be do-able.  But a single subnet across a WAN also implies broadcast across the WAN connection (this is the only noteworthy issue I can think of now, but then again I'm still waking up).

Also note that there are other routing schemes that can ensure internet connectivity that can be used.  (and for the life of me I can't think of them right now).

Regards,
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
LVL 11

Accepted Solution

by:
grsteed earned 2000 total points
ID: 16270956
As others have mentioned, if both routers/paths are on the same LAN it would be possible.
 

      LAN
        |
        |------ router1 -------WAN ---------remote router -----------Internet
        | H
        | S
        | R
        | P
        |------ router2 -------WAN ---------remote router -----------Internet
        |

In this scenario, you could set up 2 standby groups for HSRP. In  standby group 1, make router 1 active and router 2 standby by using a priority of 110. In standby group 2, make router 2 active by giving it a priority of 110. (100 is the default priority, giving a higher number makes that interface active)

For example

hostname Router1
!
interface ethernet 0
ip address 1.0.0.1 255.0.0.0
standby 1 ip 1.0.0.3
standby 1 preempt
standby 1 priority 110
standby 1 timers 5 15

standby 2 ip 1.0.0.4
standby 2 preempt
standby 2 timers 5 15


hostname Router2
!
interface ethernet 0
ip address 1.0.0.2 255.0.0.0
standby 1 ip 1.0.0.3
standby 1 preempt
standby 1 timers 5 15

standby 2 ip 1.0.0.4
standby 2 preempt
standby 2 priority 110
standby 2 timers 5 15

This configuration can give you the added benefit of load balancing if you split the default gateway between your clients (half use .3/half use .4) The inbound traffic (from the Internet) will use both paths anyway.

Cheers,

Gary



0
 

Author Comment

by:tozden
ID: 16273125
Dear all;

Thank you very much for your contributions. I have been satisfied by the answers; the HSRP is can be implemented within the same broadcast domain as I have known. Although it is not very effective, I think it is possible to implement my question design by use of VPLS or some other technique.

Unfortunately I had to select only one of the answers; I think the point are deserved by Gary with the careful answer and configurations.
Regards;
0
 
LVL 11

Expert Comment

by:grsteed
ID: 16273652
Thanks,  glad I could help.

Gary
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question