• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1961
  • Last Modified:

Hp allinone 7410 cannot print or scan unless user has administrative account

Title: HP AllinOne 7410  Only Administrative Group can print or scan all other groups get print failed error, failed to connect when trying to scan, If I get rid of HP's Printer port and use MS standard TCP
asked by BillAndrews01 on 11/04/2005 04:17AM PST  
This solution was worth  500 Points and received a grade of A  
 
 



Using the hp all in one 7400, only accounts that have administrative rights can print or access the device. It is connected wireless.  I believe that there install program failed to  give access rights to their custom ports.  Because If I configure a standard MS tcp port, all groups are able to print.  But this does not fix the issue about accessing its scan feature.
HP has been no help.  The printer properties Security is set to all of the groups USERS etc read access, even tried giving them full control.  But did not work.

I get   Win32 error code returned by the print processor: 67 (0x43).

This printer works fine with windows XP professional SP1, But this computer is using XP professional SP2

HP has a few reports of the same problems but basically no solution.


 
 Send to a Friend     Printer Friendly   See Solution  
   
 Comment from MrBillisMe
Date: 11/04/2005 06:30AM PST
 Comment  


Some hardware is tough to get around but since it uses software give user full permission to the software in the registry and in the Windows programs.

You can also make a user just a power user rather than a full administrator.

The software .exe should be added to the Windows, SP2, Firewall as an exception as well.
 
Comment from BillAndrews01
Date: 11/04/2005 10:56AM PST
 Your Comment  



I have tried all the different groups,  none work.. ie power users group fails to allow printing as well, If i give the account
admin. rights, everything works fine.

I have used the registry monitor program from system internals, in order to determine if there are access violations when accessing the
registry.. but there are none that i can find.  

HP suggested that I give the everyone group  full access to the classes hive, all the HP software hives.. I did this but it did not fix the issue
either.
 
Accepted Answer from MrBillisMe
Date: 11/04/2005 12:05PM PST
Grade: A
 Accepted Answer  


I assume you have tried disabling the Windows Firewall.

You might try another SP2 machine to see if it can scan, just to make sure this is not a problem specific to this PC.

Install the 7400 as a local printer and create a port pointing back to the server.
 
Administrative Comment from Venabili
Date: 12/27/2005 11:17AM PST
 Administrative Comment  


No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I will leave the following recommendation for this question in the Cleanup topic area:
   Accept: MrBillisMe {http:#15227315}

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Venabili
EE Cleanup Volunteer
 
Administrative Comment from Computer101
Date: 12/31/2005 08:25AM PST
 Administrative Comment  


Forced accept.

Computer101
EE Admin
 
0
BillAndrews01
Asked:
BillAndrews01
1 Solution
 
Bob StoneIT GuruCommented:
So, you are saying that you still need help with this?

Can you give a brief rundown on what you have tried to do to fix it since the old question?
0
 
BillAndrews01Author Commented:
I have done the following:

All programs that pertain to the HP printer/scanner have been given complete access to NIS firewall
Have even tried with the firewall completely uninstalled.
I thought i might have a problem with NIS.  
I have a new Dell with Mcafee ...It does not work with mcaffee either.

On the Printer security tab All users / acconts on my computer have been given Allow permissions for Print, manage documents,manage printers, (also the everyone group is assigned allow permissions for Print, Manage Printers, Manage Documents)

HP's knowledge base suggested changing permissions in the registry hives for HP, and several other hives,  I followed their suggestions, but Doing so did not help.

The Port is the Standard HP tcp/ip printer port.
I if change this and configure an MS standard printer port, I am able  to print from accounts that do not have administrative permissions.
But, This does not fix the problem of not being able to Scan.

Also,  I have tried to assign other groups for example power user, instead of admin.  This does not work either.
I am using the printer via a wireless network, secutiry WPA
is there any chance that there are some other permissions missing due to the wireless network.

I have run Regmon from Systeminternals, and there is no indication of any registry permissions problems.
also I have run filemon, and there is no indication of not being able to access the spooler directory or any permissions errors

Like i stated If I give All accounts Admin group priv.  all works fine... But this is a horrible thing to have to do

Thanks for your help
0
 
CallandorCommented:
This sounds more like an OS-specific issue than a hardware issue if you had it working with sp1 but it won't work with sp2.  I would focus on the things that frequently crop up when updating to sp2, such as the need for updated drivers.  Testing from another machine and doing it with a wired connection are also good things to try.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
BillAndrews01Author Commented:
I have the latest drivers installed from HP.
All the latest software etc.
Currently I do not have a computer with Sp1 installed.
I have a new computer with XP professional SP2

Most likely it is not the printer itself, but Hp's specific drivers
0
 
BillAndrews01Author Commented:

I just tried connecting the printer via the USB port.

WHen it is connected using the USB,  Everything works fine.

There are no print failures,  if the user account does  not administrator priv.

It seems strange that printing  fails using ethernet, but works fine with USB.

are there other settings that must be configured, besides security on the printer, firewall, in order to allow printing by a normal user ?
0
 
CallandorCommented:
It seems like you may need a separate program for scanning on the network, since someone is selling such a product: http://www.remote-scan.com/share-scanner.php
0
 
jstumpfCommented:
The solution proposed (using a "Standard TCP/IP" port) did allow me to print however it also lead me to the root cause of my problem.  While configuring a new, "Standard TCP/IP" port, I noticed that the "HP TCP/IP" ports that had been configured during the OfficeJet installation had used the "automatic hostname" configured on the printer rather than the IP address that I had supplied during the installation.

As Administrator, go to "Printers and Faxes" -> HP OfficeJet 7400 series -(RightClick)> Properties -> Ports -> Configure Port, there you will see the "Hostname or IP Address" field.  I replaced the "unknown" hostname with the actual IP address of my printer.  Repeat the process for the "HP OfficeJet 7400 series fax".
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now