Cisco 1720 - Can't configure VLANs

Hi,

Am trying to set up a VLAN on a router and it doesn't recognise the command VLAN or VLAN database.

My IOS is "flash:c1700-y-mz.121-3". Is this the reason why and if so which IOS do I need?

cheers,

YVS.
yvsupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

surgenetCommented:
Routers don't support the creation of VLANs unless they have a switch WIC card (i.e. HWIC-4ESW) installed in them. The router will manage the VLANs via a trunk and direct traffic. The VLAN work needs to be done at the switch.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mattacukCommented:
silly question, but are you trying to access this command in enabled mode, or Config mode?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.