VPN Error 806 and Error 721

Posted on 2006-03-23
Last Modified: 2008-06-25
I setup Server 2003 RRAS, the user has remote access with Dial-uin allowed
Linksys router WRV54G has a passthrou to ports 1723 both and 47 both to server.

When I try to VPN in from another location using a Windows server 2003 I lets me then it tries to verify username and password, it takes about 60 seconds and then comes back with
"Disconnected Error 806: a connection between your comuter and the VPN server has been established, but the VPN connection cannot be completed. The most command cause for this is that at least one internet device (for example firewall or router) between your computer and the VPN server is not configured to allow GRE protocal packets. Verify that protocal 47 GRE is allowed on all personal firewall devices or routers"

When I try it from a Windows XP computer I get a the same but a diff error:
"Disconnected error 721 the remote computer did not respond"

I can VPN to other sites from both of these computer.

Question by:jsarinana
    LVL 77

    Expert Comment

    by:Rob Williams
    GRE is protocol 47, not port 47.  On the WRV54G you need to enable port forwarding of TCP PPTP packets on port 1723 to the VPN server as you appear to have done, but to enable GRE pass through on the WRV54G you need to go to the Security section of the router and on the VPN tab enable the setting "PPTP pass through".
    See if that helps, if you have not already done so. If not, what make and model modem are you using.
    LVL 1

    Author Comment

    Thanks RobWill,
    The router is a Linksys WRT54G. When I go into the security section/VPN I have ipsec, pptp and L2tp enabled. I do not see anything on GRE pass through. I do have port 1723 open to the server. The firmware is v2.02.7 02/27/2004

    Any other suggestions?
    LVL 77

    Accepted Solution

    On the WRV54G PPTP pass-through is GRE pass-through. I don't know why they can't call it that. So, it sounds like you have it configured properly.

    Not that it matters for this part of the configuration, but is it a WRV54G or a WRT54G ?  You mention both above.

    I was asking about the modem make and model, as some are combined modems and routers. If yours is one of these it will need to put in Bridge mode if that has not already been done. The combined units are usually set up to do NAT (Network Address Translation) as is your router. VPN's do not work well with 2 NAT devices.

    LVL 1

    Author Comment

    It's a WRT54G. I updated the firmware and Presto it works now.

    LVL 77

    Expert Comment

    by:Rob Williams
    Great, glad to hear. Sorry I wasn't more help.
    Thank you for the points.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
    Let’s list some of the technologies that enable smooth teleworking. 
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now