We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Outlook 2003 HTML email - why don't 'background' images show

Matrix1000
Matrix1000 asked
on
Medium Priority
7,335 Views
Last Modified: 2008-11-19
I've created an html template that I want to use for an Outlook 2003 stationary and uploaded all the images I want to use in the email to my webserver and verified the path etc by viewing them in IE. I've also hard coded the full http path to the images in the html template I created.

I loaded the html template by going to Options>Mail Format>stationary Picker> New>use this file as a template. etc.

In the preview window the email shows up as intended with all the repeating backgrounds and background images I used in table cells.
Ive set the table cells to both have an html and css attribute for the background but when I create a new mail message... all the background images don't show up ....what the heck?

I've tried both.....but nothing works...

HTML
<tr>
    <td background="http://www.mysite.com/background.gif> My stuff</td>
 </tr>

-------------------------------------------------------------------------------------------------
CSS

<style type="text/css">
<!--
.centerbackground {
      background-image: url(http://www.mysite.com/background.gif);
}
-->
</style>
<tr>
    <td class="centerbackground"> My stuff</td>
 </tr>

--------------------------------
What am I doing wrong?


Comment
Watch Question

Sr. Systems Engineer
CERTIFIED EXPERT
Commented:
Security settings in outlook don't defaultly allow for downloading of images.  Some emails sent out have specially formated html to cause email when opened to hit a webserver that then logs the request and verifies that the email account is valid and live for further spamming, for this reason stuff isn't downloaded by default in outlook..

In the Tools / options menu go to security take it from restricted to internet , also under download pictures click the button and change the options.. however when you use this to send to others their settings will probably be default and they aren't going to see them.

I'm pretty sure the way around it is to somehow get frontpage involved and create an htm that includes the images with the email.  I know it works for signature items when I want to include images.

It's all security.. blame the stupid spammers...

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Commented:
Outlook 2003 replaces valid image code in HTML templates with its own internal content IDs to refer to the images. Send the e-mail to yourself and view the source when you receive it to see what I'm talking about. This adds a whole lot of text to the file, but the images included this way do show up in the e-mails on the receiving end. Problem is, Outlook doesn't replace the image code in style declarations so it just ignores the specified image and doesn't display it.

Like DeadNight mentioned, security settings are part of the problem here and I can understand why they are this way by default. If you have an e-mail communique that users want to receive they can add your e-mail address to their trusted senders list and change their settings to download images from those trusted senders without having to view images on every e-mail by default.

If you can get them to do this, and if you specify the images in the head section rather than inline (inline doesn't seem to work for some reason), they will be downloaded when the recipient views your e-mail.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.