?
Solved

Wierd Multi Boot hal.dll/boot.ini

Posted on 2006-03-23
12
Medium Priority
?
2,216 Views
Last Modified: 2008-05-29
I only have 125 points since I'm new to this site and haven't quite figured it out yet.

But heres the run down.

I have a custom built tower for a year now. I started out with 2 normal ATA100 drives in raid 0 with XP Pro installed.

I then upgraded to 4 SATA150 drives with XP Pro in raid 0+1. No problem there.

Then I get the wild hair to try some Linux distros on the two ATA100 drives. I add them in and everything is peachy. I get two flavors of Linux on the drives all OS's are bootable and I'm happy for about 48 hours when I get hal.dll errors and another that says my hardware is miss configured.

I tried recovery console multiple times. Never prompts me to choose or login to the XP installation. I try anyway to rebuild the boot.ini. Bootcfg says it can't be found. DIR shows its there. So I try to use Attrib to change the attributes. Get invalid Attrib errors.

So I rebuild the whole setup again. Same results as before. Every thing is fine for awhile and then bam hal.dll errors again.

So I decided to do it one more time and this time I walk away before the "Press any key to boot from CD" message to start the reinstall. Well I come back couple min latter and XP booted like it should. I'm thinking ok that was a fluke. So I reboot and it boots fine again. I then remember the XP CD is in the drive. I remove it and reboot again. Bam hal.dll error. I place the disk back in and hit reset it boots fine again. I try different disks but unless its the XP Disk I have hal.dll errors.

Anyone know how I can fix this as I would really like a dual boot or triple boot system. I think its got something to do with the sata drives being in a raid array but not sure.

Machine specs
AN8 NF-CK804 (Bios 20)
AMD Athlon 64 3200+
ATI X600 Pro VIVO 256MB PCI-X
2 512MB DDR400 CL3 PC3200 (Dual Channel)
4 250Gig WDC RE 7200 Rpm 8MB Cache Serial ATA150 (Raid 0+1)
2 80 Gig Seagate Barracuda 7200 Rpm 2MB Cache ATA100
Nvraid/NvMass Storage Driver v1.05
Lite On DVD+-R/RW-CD+-R/RW
XG Magnum 500 watt
Windows XP Pro SP2 (w/all critical updates)
0
Comment
Question by:tacouch
  • 5
  • 4
  • 2
11 Comments
 
LVL 69

Expert Comment

by:Callandor
ID: 16276955
When you used the RAID array, did you press F6 and install the RAID drivers from the floppy that was supplied?  You can't boot from a RAID array unless you have the driver installed.
0
 
LVL 10

Expert Comment

by:tfjeff
ID: 16277695
boot to the windows CD, use f6 to load the raid drivers, enter recovery console, run bootcfg/rebuild
further information at:
http://support.microsoft.com/kb/291980/en-us
http://support.microsoft.com/kb/317521/en-us
of course, this won't cater to your linux installation, you will need to use a linux bootloader like lilo or grub for this.
0
 

Author Comment

by:tacouch
ID: 16282796
Yes I installed the raid drivers during inital install of the OS's.

Bootcfg doesn't help.

It still has to have the XP setup CD in the DVD Drive in order for my boot to work which makes me think its pulling a file off the CD or causing drive letter asignments to change.

At this point Linux isn't even installed anymore because of this boot issue.

I have two 5gig partitions on IDE one and a 64gig unformated partition. One has XP on fat32 the other is just formated fat32.

IDE  2 has an unformated 74gig partition.

Raid Array has another XP install on it. Using XP Bootloader I can boot just fine to the IDE1 XP install but booting to the Raid array I HAVE to have the XP Setup CD in the drive or it says the hal.dll is missing or corrupt.

This is the contents of my boot.ini

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(2)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(2)partition(1)\WINDOWS="XP Professional SATA" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

The paths look right for each as rdisk 0 is IDE1, rdisk 1 would be IDE2 and rdisk2 is the raid array. Although I'm wondering if multi and disk need to say something else for the raid array as it is on SATA port 1 and not IDE Master1.

Any other suggestions. I had 5 more points given to me so I up'd the points.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
LVL 10

Accepted Solution

by:
tfjeff earned 90 total points
ID: 16283072
Here's what microsoft says about a hal.dll missing/corrupt:
http://support.microsoft.com/?kbid=314477

it appears that issues with boot.ini can cause the problem (however, if you've already run bootcfg/rebuild and that didn't work, this is probably not the case).  It also says that a missing or corrupt ntoskrnl.exe file can cause this error, try replacing ntoskrnl.exe.
0
 
LVL 69

Expert Comment

by:Callandor
ID: 16283135
Do your SATA drives have a different compatability mode that they can be accessed as? (legacy mode, enhanced mode, etc)
0
 

Author Comment

by:tacouch
ID: 16283752
These are the SATA drives I'm using.

http://www.westerndigital.com/en/products/products.asp?DriveID=87

Doesn't make any mention of a legacy mode. In fact the only thing on the label is a note about setting a jumper for passing FCC interference tests called spread spectrum clocking and another jumper for allowing the drive to power up in stand by. Currently the jumpers are on pins 1/2(default disables spread spectrum clocking) and 3/4 (to enable the SATA 150 speed other wise it defaults to ATA 100 speeds).
http://www.westerndigital.com/en/library/eide/2579-001037.pdf
0
 
LVL 69

Expert Comment

by:Callandor
ID: 16284332
What I meant was the BIOS for the SATA drives - does it have a compatability mode for access?  Sometimes, one has to use a different access method to make SATA drives work normally.  Try it also in a non-RAID setup, just to make sure it's not a hardware problem.
0
 

Author Comment

by:tacouch
ID: 16286320
The only thing I can find in the BIOS is changing the boot order of the harddrives regardless of there jumper settings. This is in additition to boot device order. i.e. Floppy Cdrom HD.

Right now its set to IDE1, Raid Array, IDE2. Changing the boot order only causes more problems.

And now while tring to find anything that that relates to legacy mode in the bios it started the hal.dll error even with the XP Setup disk in the drive. Tried the bootcfg by loading the raid drivers as you suggested Callandor and now the only install, even with the raid drivers loaded, that it sees is the XP install on the IDE. I logged into the working install and looked at the boot.ini. Its exactly as is posted above. So this is defiantly a hardware issue I just have no other idea what else to try.
0
 
LVL 69

Assisted Solution

by:Callandor
Callandor earned 300 total points
ID: 16286673
There should be a RAID controller BIOS that you press a certain keystroke to get into at boot time.  It may be a hardware issue, but you don't know if it might just not like the current configuration.
0
 

Author Comment

by:tacouch
ID: 16293386
Your correct there is a controller bios accessed via F10 on boot but the only options are which drives to use. The level of Raid and whether the array is bootable.

I've ended up reformating again. This time I installed with just the raid array active. I then made sure the box would boot correctly without the XP setup disk multiple times over the course of the last two days and so far it has. I then re-enabled the IDE drives but didn't format them. So far so good. I'm post from this machine instead of my laptop.

My next step will be to attempt to install a Linux Distro's on the other two drives and see if I get a failure to boot. I think I'll do the first one and alternate back and forth a day or two seeing if anything bites the dust.
0
 

Author Comment

by:tacouch
ID: 16588844
Well what I ended up doing was creating 2 bios profiles and setting the bios to hide the IDE drives from the SATA drives when booting to windows and hide the Raid Array from the Linux distros when booting to Linux. Its a pain in the butt to have to go into the Bios every time I want to switch OS's but thats the only way around the issue.

Spliting the points between the Callandor and tfjeff.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
This is about my first experience with programming Arduino.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Suggested Courses

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question