We help IT Professionals succeed at work.

Group Policy Background Color

lkula166
lkula166 asked
on
Medium Priority
10,654 Views
Last Modified: 2013-12-04
I'm having trouble setting the background color to black for PCs within my organization using Group Policy.  I realize that Group Policy doesn't allow for this inherently and so I researched other ways to do this.  I didn't want to do this through a login script and "tatoo" the registry with the correct entry.  I created an adm file to work with Group Policy that I found by another user on here, robbe, and it is here:

CLASS USER
   CATEGORY "Desktop"
      POLICY "!!ChangeBGColor"
         KEYNAME "Control Panel\Colors"
         PART "!!ChangeBGColor" EDITTEXT
            VALUENAME "Background"
            DEFAULT "0 0 0"
            REQUIRED
         END PART
      END POLICY ; !!ChangeBGColor
   END CATEGORY ; Desktop

[STRINGS]
ChangeBGColor ="Background color"

When I add this to Administrative Templates within a GPO, nothing changes.  I then came across a nice program by Desktop Standard, called PolicyMaker Registry Extension which installs into GPMC.  When you go to edit the GPO now, it adds a registry section in there which allows you to select the exact registry key and value that you desire.  This doesn't work at all either.  The standard settings work fine within GPO, but either of these methods I have tried do not work.  I have left a question in a forum for the Registry Extension program, but does there exist a simpler solution to this problem?  Thank you in advance.
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2006
Commented:
when you add the template you need to play with the filter to allow for it to be viewed! add your ADM in and say ok

now under the white screen on your right where the should be settings right click and select view and filters. untick only allow policies that can be fully managed

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
You know I forgot to mention that this was a 2000 domain that I was working on, seems to be easier on 2003, though the GPMC which runs on XP makes this much easier to administrate.  And thanks for the info, I was only half way there.  I had loaded the template, and then never enabled the setting I wanted.  Thanks again.

P.S.  I came across another adm file in a post by NJNetworks which seemed a bit clearer and may help other people.

CLASS USER
 CATEGORY "Desktop"
  CATEGORY "Custom desktop options"
   KEYNAME "Control Panel\Colors"
   POLICY "Background color"
    EXPLAIN "Allow you to control the background color of the user's desktop."
    PART "Enter the RGB values of the user's desktop background (ex: 128 128 128)" TEXT
    END PART
    PART "Color" EDITTEXT
     REQUIRED
     VALUENAME "Background"
    END PART
   END POLICY
  END CATEGORY
 END CATEGORY
CERTIFIED EXPERT
Top Expert 2006

Commented:
good stuff :)
David HaycoxConsultant Engineer

Commented:
Neither of the templates above worked for me as is.  Here's how I got it to work (only a few changes):

CLASS USER
 CATEGORY "Desktop"
 KEYNAME "Control Panel\Colors"
  POLICY "Background color"
   EXPLAIN "Defines desktop background colour in RGB"
   PART "Background color" EDITTEXT
    VALUENAME "Background"
    DEFAULT "0 0 0"
    REQUIRED
   END PART
  END POLICY ; "Background color"
 END CATEGORY ; Desktop

Commented:
I'm trying this also. Tried all of the above - no good.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.