The Microsoft Vodual Studio Remote Debugging Monitor on the remote computer does not have permission to connect to this computer

I get the following error when I try to remote debug from an XP sp2 machine on a Win 2003 Sp1 Server

"The microsoft visual studio remote debugging monitor on the remote computer does not have
permission to connect to this computer"

I am logged in as administrator on the Win 23k machine and as administrator locally on the xp machine
both are in the same workgroup.

Beend through 4 thoudand setup blogs but none worked .. any ideas?

ASP.net 2.0 C# Web Application
LVL 12
williamcampbellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

williamcampbellAuthor Commented:

  Finally solved this one.

  You must have an account on your XP box that has a user AND password the are exactly the same as the NT Server 2003.

So these are the steps then for remote debugging ASP .Nt 2.0 Web Applications

1) Create Account Bob on XP box - log off log on
2) Create Account Bob on Server - log off log on
3) Install ASP.Net 2.0 on Server
4) Install Remote Debugging from the VC 2005 CD on the Server
5) On Server Run msvsmon.exe from C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\Remote Debugger\x86
6) On XP turn off your firewall
7) Under XP go to LocalSecuritySettings - LocalPolicies - Security Options - Network Access: Sharing and security model for local accounts - set this to "Classic"

Wooohoo Remote Debugging

I hope this saves you 2 days as that what it took me to figure it out.

Wc
0
williamcampbellAuthor Commented:
Recommend PAQ and points refund to a charity near you...
0
EE_AutoDeleterCommented:
williamcampbell,
Because you have presented a solution to your own problem which may be helpful to future searches, this question is now PAQed and your points have been refunded.

EE_AutoDeleter
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.