hotplug usb problem

Hello! I recently upgraded my kernel from 2.4.6 to 2.6.13, using the pre-compiled kernel from the slackware 10.2 cd's.
 Everything went fine, except that my hotplug is still not working. I have read every post for weeks now, and I am still not any smarter. I can't figure out why it doesn't work.
 I can see udevd running in the kde system guard, but when turning on a usb harddrive no "usb-storage" comes up in there.
 
 The "/var/log/hotplug" directory is not present
 /proc/sys/kernel/hotplug is also not present as well as
 /sbin/hotplug
 
 I am running:
 hotplug-2004_09_23-noarch-5
 udev-064-i486-2
 
 thank you!

Some of my /boot/config-generic-2.6.13:
CONFIG_HOTPLUG=y
 #
 # Pseudo filesystems
 #
 CONFIG_PROC_FS=y
 CONFIG_PROC_KCORE=y
 CONFIG_SYSFS=y
 # CONFIG_DEVPTS_FS_XATTR is not set
 CONFIG_TMPFS=y
 # CONFIG_TMPFS_XATTR is not set
 # CONFIG_HUGETLBFS is not set
 # CONFIG_HUGETLB_PAGE is not set
 CONFIG_RAMFS=y
 
 # USB Host Controller Drivers
 #
 CONFIG_USB_EHCI_HCD=m
 CONFIG_USB_EHCI_SPLIT_ISO=y
 CONFIG_USB_EHCI_ROOT_HUB_TT=y
 CONFIG_USB_ISP116X_HCD=m
 CONFIG_USB_OHCI_HCD=m
 # CONFIG_USB_OHCI_BIG_ENDIAN is not set
 CONFIG_USB_OHCI_LITTLE_ENDIAN=y
 CONFIG_USB_UHCI_HCD=m
 CONFIG_USB_SL811_HCD=m
 CONFIG_USB_SL811_CS=m
 
 # Device Drivers
 #
 CONFIG_IEEE1394_PCILYNX=m
 CONFIG_IEEE1394_OHCI1394=m

fstab

 /dev/hda5 swap swap defaults 0 0
 /dev/hda6 / ext2 defaults 1 1
 /dev/hda1 /media/betelgeuse_C ntfs ro 1 0
 /dev/hda4 /media/betelgeuse_D vfat defaults 1 0
 /dev/hdd /mnt/dvdrom iso9660 noauto,user,ro 0 0
 /dev/hdc /mnt/cdwrite iso9660 noauto,user,ro 0 0
 /dev/fd0 /mnt/floppy auto noauto,user 0 0
 devpts /dev/pts devpts gid=5,mode=620 0 0
 proc /proc proc defaults 0 0
 none /sys sysfs defaults 0 0
 none /proc/bus/usb usbfs defaults 0 0

lsmod
 Module Size Used by
 isofs 32056 0
 zlib_inflate 17024 1 isofs
 appletalk 30004 2
 ax25 50028 2
 ipx 23596 2
 nvidia 4081584 12
 snd_pcm_oss 46240 1
 snd_mixer_oss 15872 1 snd_pcm_oss
 snd_intel8x0 27968 2
 snd_ac97_codec 75388 1 snd_intel8x0
 snd_pcm 75016 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
 snd_timer 19716 1 snd_pcm
 snd 45572 8 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_co dec,snd_pcm,snd_timer
 soundcore 6880 2 snd
 snd_page_alloc 7556 2 snd_intel8x0,snd_pcm
 ipv6 225600 8
 pcmcia 30368 0
 firmware_class 7424 1 pcmcia
 yenta_socket 21516 0
 rsrc_nonstatic 11136 1 yenta_socket
 pcmcia_core 34320 3 pcmcia,yenta_socket,rsrc_nonstatic
 nls_iso8859_1 3968 1
utziAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

xberryCommented:
None of your usb modules is loaded.
Is it possible at all to start them with the modprobe command ?

Did you already go through this one:

http://www.linuxquestions.org/questions/showthread.php?p=2146390


0
xDamoxCommented:
Hi,

I belive you have to upgrade your hotplugs too, they are on the slackware CD with the kernel.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
utziAuthor Commented:
Yes, I have gone through many of those pages %)
"modprobe alone or "modprobe usb" doesn't return anything, what are the modules I am looking for?

$ ls -l /var/lock/subsys/hotplug
/usr/bin/ls: /var/lock/subsys/hotplug: No such file or directory

On the CD's I can't find anything "hotplug"..
0
utziAuthor Commented:
# sbin/modprobe usbcore
bash: sbin/modprobe: No such file or directory
# sbin/modprobe usb
bash: sbin/modprobe: No such file or directory


there is nothing "*usb" in /sbin!
0
utziAuthor Commented:
So the modules are not loaded... where are they, and how can I load them?
I have never done this b4, I am lost!
thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.