X-Deep to Linux gdm and "unknow host: CSLinux11 "


I am trying to configure X-Deep, it seems user friendly, when I try to display windows to it
from Linux by set the DISPLAY to its temprory IP address. However when I try use XCMDP
to to a connect I got a message from the X-Deep's chooser window, saying "unknow host: Linux311 "
I got confused, there really is nothing to set about allowed xdm hosts from the X-Deep side. One thing
I could think of is that there is a  /etc/hosts table on linux which suppose to have some of the
hosts entry on the local LAN. But this is a DHCP/Window XP machine, there is a no fix IP to put there.
Please offer suggestions. Thanks in advance.

Ze
LVL 1
zzhang2006ProfessorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
Your DHCP server should update DNS records.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GnsCommented:
Your "X-Deep-side-host" can't resolve the name of the "gdm-side-server"... Which presumably has a fixed address? Use that then in the XDMCP query. Or do as Andrew suggests and fix the linux box DHCP client so that it updates DNS... Or better yet, if it has a fixed address, see to it that it gets added to DNS statically.

The windoze side might be configured by little martians(:-),for all it matters... It is the client, right, which connects to the server.... which means that the server will not need "search" for its address (it might make an attempt to get the _name_, but that shouldn't matter). As I read your error, it is the windoze machine having all the trouble.
If it'd been a "connection refused" type of thing, one would've needed to look at the gdm settings (that it actually allows connections), but I don't think you get that far. So do try with the IP address. Still fail?

-- Glenn
gheistCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.
I will leave the following recommendation for this question in the Cleanup topic area:

Split between gheist http:#16277888 and Gns http:#16302252

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

gheist
EE Cleanup Volunteer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.