USB memory stick - missing drive letter - advanced query

I want to fix the missing USB drive letter problem without restarting my PC.

I have a test box here running XP Pro SP2.  It has a single hard disk, C: drive, no network drives, and I am using one specific type of USB stick.  I plug in my USB key and it is drive D: ... fine :)  Over a couple of days I am using the stick, I unplug and plug back in, it works a random number of times (10, 15, 20, etc.) then a few days later it stops, no drive letter.  :(  I didnt do anything interesting i.e. no network maps, no other USB devices except an optical mouse, I just transfered some files back and forth.

To get the drive letter back I have tried:

* Manage -> Disk Management -> Drive Letters and Paths, changing the assigned letter to all sorts (E:, F:, I:, M:, etc)

* with the USB key removed - deleting extraneous entries (easy to identify because the system is so minimal) from:
................. HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
................. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB
................. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR

After the above step I insert the key and the disk is recognised and installed again as new, but still no drive letter!

*  If I restart the PC - the drive letter comes back  *


What I find most ridiculous is that throughout all of this, at all times, the USB drive is accessible through a DOS prompt!  

Right now in file explorer I have only a C: drive, but if I open cmd prompt...



Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\WINDOWS\system32>D:

D:\>dir
 Volume in drive D is Kingston
 Volume Serial Number is 3245-14FC

 Directory of D:\

06/11/2005  16:33         2,686,976 Migo.exe
06/11/2005  16:33           699,383 MigoReadMe.pdf
06/11/2005  16:33           250,568 MigoUserManual.pdf
06/11/2005  16:34         1,789,952 SecureTraveler.exe
06/11/2005  16:34           585,823 SecureTravelerReadMe.pdf
<some files removed from text>
              12 File(s)      6,649,213 bytes
               5 Dir(s)     106,848,256 bytes free

D:\>


Why why why?!

500 points and my hat off to anyone who can solve this.

Cheers,

Colin
LVL 3
Col_HAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ian_chardCommented:
It's not a fix but it will help your frustration a little. Create a shortcut on your desktop that goes to D:

Other than that, check for updates for the drivers for your USB key, controllers, etc.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Col_HAuthor Commented:
drivers up to date - thx for frustration reduction suggestion but this is an ideology thing
0
JimsZCommented:
I would say to try to go into disk management properties.  Right click on my computer and click manage.  Then go to disk management.  Right click on the memory stick and click properties and go to the hardware tab.  Once you find your memory stick in the list,  click on it then properties.   Click the volumes tab at top, then click "populate" at the bottom.  It should then run through the memory stick and verify all information held on it, then should map the drive.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Col_HAuthor Commented:
ok will try this :)
0
dante1001Commented:
It is a bug in XP SP 2.
Go to Disk Management and assign it a letter near the end of the alphabet to prevent it colliding with other drives
It should appear fine next reboot and keep doing so.
0
Col_HAuthor Commented:
dante1001 - this does not work in this particular instance, i have tried all of the letters
0
f-kingIT support technicianCommented:
Hi
Does it work fine on a different machine ,does it maybe have a lock switch that is write protecting it or something?
0
f-kingIT support technicianCommented:
Tell me is it a usb key or stick
0
Col_HAuthor Commented:
I make no distinction between "usb key" and "usb stick"

It works fine on other machines, as indeed it works fine on this machine, until it stops working fine.

This problem is no more complicated than:

PC with one C drive
insert USB memory stick - fine it has a D drive
remove memory stick - fine D drive is gone
insert memory stick - this time no D drive, but drive is memory stick is recognised, installed, and D drive is accessible through command prompt


The solution is not change letter in disk management, and no registry modifications I have tried so far have helped.  Of course, restart the machine and the D drive magically re-appears... a ha! I have an idea, I will kill and restart the explorer process...

I have also yet to try JimsZ excellent sounding suggestion.  I need to it to randomly break again to try solutions... ;)
0
mluther223Commented:
I have been experiencing a similar problem,  and I believe in my case the problems is that I have mapped drives, and they take the drive letter that the USB drive is trying to take.  My solution was to remap my "e" drive to a different letter, and then when the USB drive is plugged in it takes the "e" letter just fine.
0
Col_HAuthor Commented:
Hi mluther - thanks for your input, however, I can say with certainty this is not the problem, or solution, in my case.

Glad you got yours sorted tho :)
0
Gary CaseRetiredCommented:
... as a matter of interest, are you doing a "Safely Remove" every time before removing the stick?
I've found that XP will get "confused" if you do not -- resulting in exactly the symptoms you're seeing.   Additionally, I second the above comments about being sure you map the drive to a letter that will not result in any conflict with mapped network drives -- this is a frequent cause of what you're seeing.   Just go to Disk Management and "Change Drive Letter" to a letter that's well out of the way of anything else you might possibly use.

0
Col_HAuthor Commented:
OK - once more...

**  I have tried changing the drive to every possible letter **


IN ADDITION...

I have a standalone test system with only one hard disk *and no network mapped or other drives at all*


ALSO IN ADDITION...

The drive letter is successfully assigned because I can copy and access data on the memory stick via the DOS prompt!  This says to me it is not a drive letter problem, it is an explorer problem.


Please note also that (as far as I am aware, in detailed knowledge of the registry I do not profess expertise) the available/assigned drive information is stored in the following registry area:
HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

I have removed redundant keys found in this area from previous times I have plugged in the key.

I am afraid to say, whilst I thank you for the input, that this suggestion sucks, please dont offer me it again.


Yes - I always do a Safely Remove.

0
Col_HAuthor Commented:
I guess it is possible that every drive letter may have been assigned which is why changing the assigned letter has no effect.   I seriously doubt that this is the cause of the error, however, as each time the key is inserted it is assigned drive letter D, until it breaks.  Even then it is still drive D in the DOS prompt.  It is simply not a drive letter problem.
0
Gary CaseRetiredCommented:
I noted you said you'd "tried every possible drive letter" ==> but it wasn't clear whether you'd done that by registry hacking (since you indicated you'd made a bunch of changes) or by using the Disk Manager's "Change Drive Letter" function.   My key question was whether or not you were safely removing the device.

In any event, this is a not-uncommon issue with XP.   The most common "solutions" (workarounds would be a better term) are:  (a)  reboot (as you've noted, this works, but is a pain);  (b)  simply create a shortcut to the drive (as suggested in the very first post);  or (c)  replace Explorer with a 3rd party Explorer-equivalent, which can not only resolve this but also provide a few extra features that Explorer does not have (tabs, folder-size display, etc.) -- such as the excellent ExplorerXP (http://www.explorerxp.com/).   I'd suggest you try the latter, as that may very well resolve your frustration -- and the tabbed views are very nice.

0
DisorganiseCommented:
Have your tried typing "explorer d:" at the run command (start/run) to see if that 'wakes up' explorer?
0
Col_HAuthor Commented:
garycase:
(c)  replace Explorer with a 3rd party Explorer-equivalent, which can not only resolve this but also provide a few extra features that Explorer does not have (tabs, folder-size display, etc.) -- such as the excellent ExplorerXP (http://www.explorerxp.com/).  


I like this suggestion and will give it a go - thanks.  Unfortunately I ask for myself, but also a large number of users and changing all of their explorers is a big step to take.  At least I can fix it for myself tho - lol ;)

I have to add that I think:
* Manage -> Disk Management -> Drive Letters and Paths, changing the assigned letter to all sorts (E:, F:, I:, M:, etc)

is pretty clear.  Nevertheless I apologise for shouting, long day, and thank you for the suggestions.



Disorganise:
Have your tried typing "explorer d:" at the run command (start/run) to see if that 'wakes up' explorer?


No - excellent suggestion!  Unfortunately (sort of...) I still havent managed to break it again despite unplugging and inserting again many times...

I will let you guys know how I get on probably on Monday.  Thank you all for your suggestions, there are many things here I havent tried - surely one of them will work!

Cheers all - have a good weekend.
0
Gary CaseRetiredCommented:
Let me know what you think of ExplorerXP.

By the way, "explorer d:" at the run command is the same thing that ian_chard suggested and I listed as (b) above -- except instead of having to type it every time we were simply suggesting you make it a shortcut command on the desktop (the target of the shortcut would be "%SystemRoot%\explorer.exe D:").
0
PeregianCommented:
get tweakui from m$ powertoys and look in the my computer section at the drive letter assignment.
0
motaz_mohamedCommented:
Did you try scanning your computer for viruses and spyware. I had this problem with one of the computers and could never imagine it was a virus problem because it had Norton Antivirus corporate edition installed. But at the end of the day it turned to be a virus called Hidrag.A which I was able to remove by a free tool called vcleaner which you can find on this link free.grisoft.com
After removing the virus, the problem disappeared.
0
nobusCommented:
>>  the USB drive is accessible through a DOS prompt  <<  you can also access it from disk management, if you select explore; sometimes it even works in the normal explorer if you click refresh.
It is a real pain with usb devices nowadays.
I hope some one finds the cure
0
CGretskiCommented:
have certain drive letters been hidden from explorer?  (can be done through Tweak UI)

Also I believe there is a setting in group policy to disable certain drives ( only applicable if your machine is on a company network that uses active directory/windows server)
0
PUNKYCommented:
Have you tried formatting the stick?
0
Col_HAuthor Commented:
Hi All

It is definitely not a virus or spyware, and there has been no powertoy or group policy tweaking/configuring of drive visibility or availability.

Re: formatting the stick - I dont think this can be associated with my issue because the drive is working and accessible via a DOS prompt, copying to and from is fine, just not trough explorer - but it is possible reformatting may provide clues to the solution, so if all else fails I will give it a go and let you know.

In general; continuing thanks for the excellent suggestions, unfortunately this issue is frustratingly random and I have not had the opportunity to test the solutions suggested...  But I will at some point, and I will let you all know how I get on.

Thanks all,

Colin
0
f-kingIT support technicianCommented:
Hi
Have you tried unninstalling the usb drivers from device manager and then letting windows reinstall them again ,could be a corrupt driver.
If that does not work then check in your systems bios and make sure that Legacy USB support is disabled as this could be causing a conflict.

good Luck
0
Col_HAuthor Commented:
Sorry guys, gone but not forgotten...  i use this USB key every day, the problem just occurs very randomly.

I will let you know when it happens again.
0
CAOgdinCommented:
It appears there is a software tool designed, specifically, to solve this problem:
http://www.uwe-sieber.de/usbdlm_e.html
It is, essentially, a service that "catches" USB drive letter assignment requests, and manages them according to configuration information you supply.

We're using it to solve the following problem:
User's notebook uses "Offline files" for data kept on a server.  When attached, the data drive is D:.  When detached from network, D: points to the cache on-disk.  The user, therefore, uses "D:" for all data, whether on-line or off-.

Now, at an off-site location, they plug in a USB drive; it picks D: as the drive, 'cause Windows is too dumb to know D: is a mapped drive with offline files.  Then, when the computer returns to the office, the USB-connected CD drive gets assigned to D:, and that prohibits the mapping to the data on the server.

This program allows us to prohibit letters A-M from being used for any USB devices.  So, now the USB flash drive and the USB-connected CD drive get assigned the same letter...but who cares...it's outside the drive letter assignments that I'm interested in holding sacred.
0
Col_HAuthor Commented:
This question is not abandoned - I am still attending and will respond in due course.

The issue has re-occured just once since i initially posted and unfortunately I was not in a position at that time to test all the suggestions made.  I am sure it will occur again, however, and I would be grateful if the question can be left open until then.

Thanks,
Colin
0
Col_HAuthor Commented:
:)
0
pumaken68Commented:
Hi Col_H

I also having a same problem as you are. In the past the drive letter "become free" once the usb flash drive removed.
In the past 2 weeks I notice that the drive letter keep increment till run out of drive letter :(.

Anyone know how to solve this problem?

Thank you

0
Gary CaseRetiredCommented:
It was suggested above, but in case you missed it, this utility installs a Windows service that monitors and controls (in accordance with parameters you can set) the assignment of USB drive letters:

http://www.uwe-sieber.de/usbdlm_e.html
0
CAOgdinCommented:
Thanks, garycase.  I wondered if pumaken68 had even read that.

I've now used that program to solve another USB problem with another client's computer.  He has one of those "6-in-1" flash card readers that, when plugged in, demands six drive letters that clutter up Windows Explorer.

USB Drive Letter Management allowed us to define a single folder on an existing drive, and make each of the flash card types to be a subfolder in that folder.  That way, we can leave the "6-in-1" installed all the time, and navigate to the hard drive with the ficticious folder name mapped to the USB flash card reader when we need it.   Slick!

--Carol Anne
0
Col_HAuthor Commented:
OK.  Problem re-occured - here are the results:

ian_chard - create a shortcut:
and
Disorganise - explorer d:
These approaches both open an explorer window that shows the contents of the memory stick - the address bar is blank, and a normal file explorer window still doesnt show the drive in My Computer, even though it is cleary present.  Its a working solution, but not perfect, thank you for suggestions.  ian for quickest response will get most of the points here.


JimsZ - disk management -> populate:
I tried your steps, clicked populate, and it correctly identifies that d: <name> is a volume on the drive.  Unfortunately, file explorer still refuses to show the drive.  Great suggestion - but nil points. Sorry.


garycase - suggestions + patience + explorerXP:
Thanks for the help, and pointing out that ian_chard had the same solution.  ExplorerXP correctly shows the drive!  Unfortunately stubborn stupid windows explorer still refuses to tell me the truth... but nevertheless another working solution.  Additional points to you - and thanks.


Everyone:  Thanks for the good suggestions, sorry we didnt find a perfect solution, but then sometimes I guess Windows just needs to be restarted ;-)

Col
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.