FE mail routing to public folders on BE

Hi folks,

I can't seem to send emails to my mail enabled public folders from external addresses. I can however send emails to them from my outlook client which is connected to the BE server. When it's sent from an external source it sits in the queue of the FE server in the "local Delivery" section.

I have the following setup.

Exchange 2003 SP2 FE
Firewall (all ports configured correctly)
Exchange 2003 SP2 BE

Recently I ran an eseutil /d on both the mailbox and the public folder stores.
I have checked both the databases with the eseutil /mh command, both are fine.
I have also checked the public folder store with the isinteg -test alltests command
I have stopped and restarted all services
I have restarted both servers
I have restored the public folder store from a backup taken before the eseutil /d command was done, it failed to mount and had a "dirty shutdown" state, I ran the eseutil /p command on it and the store then mounted, it also has a clean state when eseutil /mh was ran.

After all this, emails sent from my dave@yahoo.co.uk account to an address of a mail enabled public folder still fails.

any thoughts?
Dave  
Dave_h194Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MikeeMiracleCommented:
I know you need to grant Contributer permissions on the public folder for Annonymous for it to recieve mail externally.  We have mail delivered direct to the BE so cannot say if it's usual for the mail to be stuck in the FE if this isn't set.  

Worth checking the permissions though :)
0
Dave_h194Author Commented:
Hi Mikee,

looks like the permissions are fine. Cheers anyway, worth a shot.

On another thought, why are these emails in the "Local Delivery" queue. Surely like all my other emails they should be in the "BEServername" queue?

Dave
0
aa230002Commented:
Do you have Public Folder store mounted on your front end server? Its not supported
Dismount and delete the public folder store from your front-end server and then, restart your IS service. Things should start working.

Thanks,
Amit Aggarwal.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Dave_h194Author Commented:
Hi aa,

here's what I've done...

Dismounted the public folder Store.
Then right clicked the dismounted store and select "delete"
it gives me an error "the public folderstore is offline, blah blah, can't determine if it can be removed safely etc.etc., bring the public folder online"

so I remount it
Then right clicked the store and select "delete"
it tells me that "you cannot delete this public folder store as it contains replicas, move replicas etc. etc."
I right click the public folder store and select "move all replicas"
it gives me an option of selecting my only other exchange server, my BE.
Then it gives me an error "the token supplied to the function is invalid"

Dave
0
Dave_h194Author Commented:
I don't know if the "the token supplied to the function is invalid" error is related to the SSL certificate I have installed on the FE for HTTPS OWA. The certificate is from easySSL, it's different from the name of the server. IE the SSL is for email.domain.com, the servername is server-a.domain.com.
0
aa230002Commented:
Stop the information store service on the Front-end server and then try to delete the public folder store.

Thanks,
Amit Aggarwal.
0
aa230002Commented:
You dont have any mailboxes on the front-end server, so all data in the public folder store would have been replicated from your back-end server and you have the copy of the data in your backend server. You need not to worry about any data in the PF store on your front-end server.
You can safely delete this and then, restart IS service once on both front-end and back-end server.

Thanks,
Amit Aggarwal.
0
Dave_h194Author Commented:
OK so now I've done this...

Stopped the IS service
Then right clicked the store and select "delete"
it gives me an error "the public folderstore is offline, blah blah, can't determine if it can be removed safely etc.etc., bring the public folder online"

I can't mount it as the IS store has been stopped.
0
aa230002Commented:
It cant determine if it can be removed safely.. But it should give you an option to continue at your own risk.
and option if.. you still wanna continue and delete the store. You can select "yes" safely there.

Thanks,
Amit Aggarwal.
0
aa230002Commented:
if still it doesnt work. another trick.
Dismount the PF store on FE, rename the pub1.edb and pub1.stm file from your windows explorer. This will also help you as you have taken the backup of public folder store from FE.
Now, mount the store, it will create new black pub1.edb and pub1.stm. and now, try to delete the store in the mounted state.

Thanks,
Amit Aggarwal.
0
Dave_h194Author Commented:
I've already deleted the pub store from explorer, then mounted the store again which re-created the store. It still wouldn't allow me to delete it.

When I try to delete the pub store when it's dismounted I get no option to continue. I only get an "OK" button. If I hit the OK button the message dissapears but nothing happens. It's like I've got to do what it says before it will delete.

Dave
0
aa230002Commented:
hmm.. try this ->
Go to your backend server and then from there remove the replica for your front-end server. and then wait for sometime to replicate this information between servers or do the force replication using Send Hierarchy from your backend server to your front-end server.
Once all the replicas are removed, you should be able to delete the PF store.

Thanks,
Amit Aggarwal.
0
Dave_h194Author Commented:
Sorry to be dumb, but how do I remove the replica for my FE server?
0
aa230002Commented:
Highlight the root public folder on your backend server and go to properties - replication tab,
and then remove the Public folder store on the Front-end server from the replica list.
Now, right click on the folder again - All tasks -> Propagate settings ->
Now, you can propagate this replica settings to all sub-folders also.

This will remove the FE pf store from replica list on all subfolders. You will have to do the same on all top level public folders on your BE server.

Thanks,
Amit Aggarwal.
0
Dave_h194Author Commented:
ok, so I've right clicked on...
"Administrative Groups | First Administrative Group | Servers | BEServer | First Storage group | Public Folder Store (BEServer)" and selected properties, now when I go into the "replication" tab the only thing I can adjust is the replication interval.

So I'm thinking this isn't the place you want me to go so I have then went...
"Administrative Groups | First Administrative Group | Folders | Public Folders" then right clicked and went into porperties. There is no replication tab.

am I looking at the wrong places?
0
aa230002Commented:
You need to select the 2nd path, and then expand "public folders" and select any of the top level public folder in your hierarchy.. How many top level public folders you see there under "Public Folders" object  here.
You will have to repeat the steps on all these top level public folders.

Thanks,
Amit Aggarwal.
0
Dave_h194Author Commented:
ok now I went into all the root public folders and not one of them contains the FEServer in the replication tab. So obviously I can't remove it.
0
aa230002Commented:
How many BE servers you have in your organization?
Even if you dont see your FEserver in the replication tab on the root, it might be there somewhere on the sub-folders.
I would suggest you to still propagate the settings from top to bottom.. so that even if we have FEserver listed somewhere it will be removed.
But, it will propagate the settings from top to bottom everywhere.. and in case, u have more than 1 server, things can be messed up. But if you have just 1 BE server. its safe.

Thanks,
Amit Aggarwal.
0
Dave_h194Author Commented:
There's only 1. How do I propogate the settings from the root folders to the sub folders?
0
Dave_h194Author Commented:
ok I've got it but this raises another question.

I right click the public folder, select "all Tasks | resend Changes", it then gives me an error "you may not send changes, either there are not enough replicas or you don't have enough permissions to the public folder stores"

I'm logged on as the administrator for the domain.

Dave
0
Dave_h194Author Commented:
ok I found another way, use the "all tasks | Manage settings"
0
Dave_h194Author Commented:
so I've now removed the FEServer from all folders. I have then tried to delete the PF from the FE and still no joy. All I receive are the same errors as before. I've even deleted it from explorer etc.
0
aa230002Commented:
Try this ->
Install Windows Support Tools on your Front-end server, Open ADSIEdit.msc - (launch it from RUN), expand Configuration container, Services, Micrsoft Exchagne, Your_org_name, Administrative Groups, Your_ADmin_group_name, Servers, Your_FE_server, and then, select and delete the Public Folder store.
Close and reopen the Exchange System Manager on FE server, you shouldnt see Public Folder store there.
Restart your Information Store service on FE and BE servers and give it sometime.

Thanks,
Amit Aggarwal.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dave_h194Author Commented:
Hi Amit,

that last solution worked a treat. I can now receive emails to my public folders from external accounts.

Thanks very much for your time and help. I've also bumped up the points to show you my appreciation.

Dave
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.