Recipient Verification aka 5.5.0 No such user (500 points)

Hi,

I would like to enable SMTP time sender verification on Exchange 2003. Domino had this functionality, as seen below:

implode:~ $ telnet dominosrv.domain.com 25
Trying 11.11.11.11...
Connected to dominosrv.domain.com .
Escape character is '^]'.
220 dominosrv.domain.com  ready at Fri, 24 Mar 2006 18:20:31 +0000
HELO test.com
250 dominosrv.domain.com Hello test.com ([22.22.22.22]), pleased to meet you
MAIL FROM: <>
250 ... Sender OK
RCPT TO: <nouser@domain.com>
550 nouser@domain.com... No such user
QUIT
221  dominosrv.domain.com SMTP Service closing transmission channel
Connection closed by foreign host.
implode:~ $

I have tried enabling the check box in ESM -> Global Settings -> Message Delivery -> Properties -> Recipient Filtering -> "Filter recipients who are not in the directory" and restarted SMTP service but this does not work. Also, when I checked the box - it warned my I must configure on the SMTP virtual IP's, but I can see nothing in the Default SMTP Virtual Server that corrosponds to this.

I am still getting a 250 at SMTP time after the RCPT TO: line...

Is this possible? Any ideas?

TIA
LVL 1
gam1002Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
There are two parts that you have to enable.

Recipient filtering on Global Settings.
Then the filter on SMTP Virtual Server.

ESM, Servers, <your server>, Protocols, Right click on the SMTP VS and choose Properties. Click on Advanced next to the IP address or all unassigned. Then click Edit and enable "Apply Recipient Filter".
Apply/OK out.

http://www.amset.info/exchange/filter-unknown.asp

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gam1002Author Commented:
Thanks for this. As I say I did check the SMTP VS - obviously i didn't look hard enough.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.