Flash drive: how to stop explorer window opening?

I own eight flash drives.  With six of them the first time I plugged them in the
Action window popped up, I selected always "Take no action" and from then on when
I inserted the drives they were recognized and no window appeared.

With two of the drives (a 128 mB SanDisk mini cruzer, and a 1 gB PNY Attache) I always
get an explorer window when the drives are plugged in.  I would like them to behave
the way the others do, i.e. when I plug them in I don't want the explorer (or any
other) window to appear.

I have tried everything I can think of but I can't change the behavior of these two
drives.

I would very much appreciate any suggestions.

Thanks.
blzuberAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PeregianCommented:
plug in device open my computer and right click the  removable drive and select properties. Theres an autoplay tab to make changes
PeregianCommented:
If that fails use tweakui from m$ powertoys

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
blzuberAuthor Commented:
Peregian....

The autoplay tab doesn't solve this problem, no matter how many times "Take no action" is selected for all file types inserting the drive still opens the explorer window.

The Tweak UI suggestion is the solution.  For those not intimately acquainted with the workings of Tweak UI here's the drill:

 In that program under My Computer: AutoPlay: Types: uncheck the option to enable autoplay for removable drives.

This is a little more global than I had hoped but it seems to work.  There is also an option to disable autoplay for individual drive letters.  I didn't try that option, becuase on occasion the flash drive is assigned a differnent letter.

Thank you for your prompt and thoughtful responses.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.