?
Solved

Link Table to DBF file on Network Server

Posted on 2006-03-24
14
Medium Priority
?
531 Views
Last Modified: 2008-02-01
Hello all,

I have the following problem, hope someone can help.
I have an Acccess Database on a Windows 98 machine that has linked tables to DBF files on a Novell Network Server and everything works fine. (With a mapped network drive)

However, when I have the same situation on an XP machine, I get the error "The Microsoft Jet Database engine cannot open the file .... it is already opened exclusively by another user, or you need permission to view its data."

When I try to access the same DBF fiels through an asp file on the same pc, the error is "ODBC microsoft access driver, XXXX  is not a valid path make sure that the path name is spelled correctly and that you are connected to the server on which the file resides".
(When the DBF file is local, everything works ok)

I have tried everything except the right solution...  review permissions, map the drive, use a UNC path, etc, etc, etc.  I'm just about to give up.

Thanks in advance for any help on this.

Cristian.
0
Comment
Question by:crodrigueza
  • 7
  • 4
  • 3
14 Comments
 
LVL 58

Accepted Solution

by:
harfang earned 200 total points
ID: 16285699
Hello,

I don't know if this will help (I don't claim I understand the problem or the solution) but I found these on the MS knowlege base:

    http://ask.support.microsoft.com/kb/271214/EN-US/
    http://ask.support.microsoft.com/kb/271228/EN-US/

while surfing on the various articles linked from:

    http://ask.support.microsoft.com/default.aspx?scid=kb;EN-US;q306518#E0MB0ABAAA

It seems to be at least related to your problem, but you will have to see for yourself :)

Good luck
(°v°)
0
 

Author Comment

by:crodrigueza
ID: 16307935
harfang,

Thank you for your reply.  I have tried some of the solutions that appear in the kb, but there are a couple that I missed.  I'll give them a try tomorrow at the office and let you know how everything goes...

Thanks again.

Cristian.
0
 
LVL 58

Expert Comment

by:harfang
ID: 16308047
If it doesn't work, I'll call for help from other experts, so be sure to let me know.
Good luck!
(°v°)
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:crodrigueza
ID: 16336321
Ok, I tried everything but with no luck.  Don't know what else to do.
Here is what I have:

1.-  From Access, I can link to a DBF file on the netware server through a mapped network drive as long as no user has it open.  (Otherwise I get the error message: ...opened exclusively by another user...").
So, from Access I link all the tables (DBF) on the server I need and I can browse them, etc. No problem.

From an asp page, I connect to the local access file via ODBC (DSN-less or with a DSN):
(for example)

set conn = server.CreateObject("ADODB.Connection")
conn.open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source='c:\inetpub\wwwroot\db1.mdb'"

- Up to here everthing's fine, no error, but :

set rs1 = Server.CreateObject("ADODB.Recordset")
strSQL = "SELECT * FROM linked_table"
set rs1 = conn.execute(strSQL)

and I get the error:

Microsoft JET Database Engine (0x80004005)
'K:\folder\subfolder' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

Where "K" is the mapped drive on the Netware Server, and the linked DBF files are in "subfolder".

On the other hand, when I try to connect directly to the DBF files from the asp page, I get the error:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC dBase Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0xa1c Thread 0x9ac DBC 0x15ece24 Xbase'.

I don't know if I've been very clear or not, but I've beeen battling through code for a while now so I almost don't even remember my name!!  Maybe it's a simple thing I simply can't see.

Thanks again...

Cristian.



0
 
LVL 58

Expert Comment

by:harfang
ID: 16339238
I did call for help. I hope one of the experts will pick up on this.
Stay tuned and good luck!
(°v°)
0
 
LVL 15

Expert Comment

by:Eric AKA Netminder
ID: 16355213
A couple of thoughts -- both of which are just the result of similar things I've run into in a long distant past. They're ideas, and if they're both off target, I won't get offended by your saying so.

1. Since this is a Win98 machine, can we assume that it's also an Access 97 db? And if that's the case, is there any chance of upgrading to A2000? The latter has a lot fewer of these kinds of problems.

2. Just an odd thought. Instead of mapping the network drive, can you refer to it using its IP address? I've never tried it -- the DSNless has always worked for me, but I've never had to work with both ASP and a Novell server.

ep
0
 

Author Comment

by:crodrigueza
ID: 16360903
Thanks for you reply ericpete, and please don't worry if any idea is off target, right now I have to try anything and everything !! I need to get this working as soon as posible.

1.-  Yes, however the XP machine  has Access 2003.
2.-  I gave it a try again using IP instead of mapped drive, but still no luck.

In the afternoon I'll continue testing, I'll post any updates.

Thanks again, I appreciate any help with this.

Cristian.
0
 
LVL 15

Expert Comment

by:Eric AKA Netminder
ID: 16362569
I just noticed this: "K:\folder\subfolder..."

Have you tried using the server's name, rather than the mapped drive's idenitification?
0
 

Author Comment

by:crodrigueza
ID: 16381342
Ok, just went back to this problem yesterday after letting it "cool off" for a while.
I don't get it.
I tried using the servers name (UNC path), ip, mapped drive letter, everything and no luck.
I once got the same error trying to access a local DBF from ASP, but then it worked, and I can't figure out what I changed.  I'm pretty sure it's kind of a permissions problem, but the thing that's driving me crazy is that a Win98 machine can do whatever it wants, (local Access DB with tables linked to DBF on a mapped drive and ASP reads and writes to those DBF) however the XP machine gets all these errors mentioned above.

I appreciate your help harfang and ericpete, I'll keep battling on with this...

Cristian
0
 

Author Comment

by:crodrigueza
ID: 16381378
One more thing, I guess now it's not so much an Access Issue, but rather a Win XP-ASP-network DBF kind of thing.
I'm new to experts-exchange, should this question be moved to another area or just leave it here?

Thanks.

Cristian
0
 
LVL 15

Assisted Solution

by:Eric AKA Netminder
Eric AKA Netminder earned 200 total points
ID: 16383407
The WinXP system assumes a network of people, so what you'll have to do is set the permissions on that machine to allow all users to see the drive; in other words, log in as the administrator of the machine, and then map the drive.

In terms of what to do with this question, there are two approaches. You're not a premium services member, so your points are important to you. Technically, we've pointed you to your answer, and by rule, that would normally mean that you should award them -- maybe with a B grade, because we didn't actually find your answer, but helped you find it. But I'd have no objection to your reducing the points so you can ask another question.

The other option is that I can see if I can find a few XP networking types to help out here; I've been around EE for a while now, and have a lot of addresses.

Your choice.

ep
0
 

Author Comment

by:crodrigueza
ID: 16385688
ericpete, thanks again.

Of course I'll award the points!!  My asking about moving the question to another area was mainly about asking the right things in the right place, nothing to do with the points.  Even though as you say the points are important for me, so is the answer to my problem, so there's no way I'll reduce the points!!  I would increase them, but that would leave me with very few in case I need help again soon!

Moving back to my headache, I'm logged on as an Administrator with the mapped drive, and just in case, I reviewed the permisions for iusr_<machine_name> and iwam_<machine_name> as well as reviewing their permissions as novell users on the server, with full access to the directory I need.

Unfortunately, still stuck.

If you know of anyone that could give me a hand, I would really, really appreciate it.

Thanks again.
0
 
LVL 58

Expert Comment

by:harfang
ID: 16386649
Hello,

I was going to suggest to try in a different TA. BTW, did you read the very last line of the article in http://ask.support.microsoft.com/kb/271214/EN-US/ ?
> NOTE: For access to be granted, the Netware Server requires that both the .dbf and .cdx files exist in the same directory. If only the .dbf file exists, the error message appears.

Well, I guess you did. You can either post a new question, with the links of the articles you have alread read so at to avoid useless answers, or just a pointer to this question. This does seem to be mainly a problem with Access, although the solution involves WinXP and Netware knowlege, to it's hard to decide...

Anyway, good luck, I hope you or someone here finds the solution.
(°v°)
0
 

Author Comment

by:crodrigueza
ID: 16402514
harfang and ericpete,

Thanks a lot for all your help.  I still haven't solved this, but I'm sure we're on the right track and theirs some tiny thing I'm not seeing.  In the meantime I'll use a "long" way to solve this, (i.e copy the dbf's to my local server and update them a few times a day).  Anyway, thanks again for everithing!!

Cristian.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
Traditionally, the method to display pictures in Access forms and reports is to first download them from URLs to a folder, record the path in a table and then let the form or report pull the pictures from that folder. But why not let Windows retr…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question