Connecting to Presentation Server via web interface

I thought I configrued my Citrix server correctly to allow users to connect to it externally via the web interface.  But I thought wrong.  They can log into the web interface, but when they try to open a published application they receive the following message:

Cannot connect to the Citrix MetaFrame server.   There is no Citrix MetaFrame server configured on the specified address.

I'm running Citrix Presentation Server 4.0.  I can use the published apps via the web interface when accessing them internally.

Thanks for the help in advance.
sim2k_supportAsked:
Who is Participating?
 
mgcITCommented:
click
Manage secure client access > Edit DMZ settings

you'll will see a default item there... just Edit it to be Alternate.

0
 
mgcITCommented:
1. have you set up an alternate address using the "altaddr" command on EACH of your PS 4.0 servers?

2. have you set up the NAT in the firewall to point the external addresses (set up in step 1) to the internal IP Addresses of EACH of your citrix servers?

3. have you opened ports 1494, 80 (or whatever your xml port is), and 2598 (if using session reliability) on the firewall for EACH of the IP addresses?

4. in the Web Interface admin console have you set the default connection to be "alternate" under "Manage Secure Client Access > Edit DMZ Settings"?

we'll start with that... your problem is that when launching an app it is probably using the internal IP Address which is not accessible from outside the network.
0
 
sim2k_supportAuthor Commented:
Thanks for repsonding and I apologize for taking so long to respond.

1.  I have set up an alternate address using the "altaddr" command.

2 & 3.  I have set up the NAT in the firewall to point the external address to the internal IP address of my Citrix server.  I had ports 1494 and 80 opened already.  I went ahead and opend ports 8080 (XML) and 2598.

4.  I think I have this set up correctly, but I'm not postive.

I believe, you're correct in say the app is using the internal IP address instead of the external.  I'm still unable to launch the app after opening the ports.  Any other suggestions?

Thanks.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
mgcITCommented:
ok do this to verify we know the problem:

After you log into the Web Interface, right-click on one of the published apps and select "Save Target As..."  

Save the file somewhere on your computer and then open it with Notepad.  The IP address of the server it is trying to connect to will be listed in the text file.  Tell me if that IP Address is the internal or external IP address of your server.
0
 
sim2k_supportAuthor Commented:
It is trying to connect using the internal IP address.
0
 
mgcITCommented:
ok then this is from step 4 listed above.

Open the Access Suite Console and look at the Settings for your Web Interface.

Click Manage secure client access > Display settings

Which options are currently enabled (shows a blue colored screen rather than gray)

and which is set as your Default?  (has a check mark next to it)?
0
 
sim2k_supportAuthor Commented:
Direct and Alternate are in blue.  Direct is set to the Default.  I'll assume that Alternate needs to be set to the default.  How do I change it?
0
 
sim2k_supportAuthor Commented:
That fixed my problem.  Thanks for the help.
0
 
mgcITCommented:
no problem.  Glad you got it working.
0
 
sim2k_supportAuthor Commented:
Any reason why users cannot connect to the Citrix desktop externally, now?  The weird thing about though is that I can conenct remotely to the desktop.
0
 
mgcITCommented:
so you are the only person this is working for?
 
Are they still able to connect internally?
0
 
sim2k_supportAuthor Commented:
I am the only person that can connect externally.  Users internally are able to connect.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.