We help IT Professionals succeed at work.

Sonicwall GVC remote client connects to TZ 170 OK but does not have DNS.

hinsonjr
hinsonjr asked
on
Medium Priority
501 Views
Last Modified: 2010-04-08
I am rather new to SonicWALL and its remote GVC client. What is the best way to setup the TZ 170 and clients so that when they connect to the HQ network, they have DNS for the HQ LAN?

I was expecting to see an IP address related to the VPN connection using ipconfig on the client, but I don't see any network adapter related to the VPN?

Do I need to configure the TZ 170 for DHCP for remote clients? If so, how do I do that?

Thanks
Comment
Watch Question

This is a fun one.

You need to set a few things on the TZ170 first to get a DHCP address on the client.

First under VPN, there is an option for DHCP over VPN. Click configure and choose "Send DHCP reuests to the following server". Put in your DHCP server's IP address. If you are using the SonicWall to do DHCP, check the boxes above it instead.

Second, in the WAN GroupVPN settings, set the virtual adapter to obtain a DHCP lease. Also, if you want them to be able to surf while connecting to the VPN, use split tunnels.

This will allow you connect with an address.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks idyllicsys. That did the trick once I re-exported the VPN configuration (it hung up before that trying to get an IP address) and imported it to the client.

Is that the only way to get the remote networks DNS to resolve names on the client (ie. by setting up DHCP) when using GVC?
You can use manual configuration or a hosts files, but realistically, yes.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.