Windows 2000 could not start because the following file is missing or corrup \system32\ntoskrnl.exe please re-install a copy of the above file

Hello there,

My PC won't boot up, it has this problem "Windows 2000 could not start because the following file is missing or corrup \system32\ntoskrnl.exe please re-install a copy of the above file"

I also have an emergency repair disk, but my PC does not have a floppy disk. I used the Windows 2000 Pro to boot up and
tried to use the emergency repair disk with an external USB floppy disk but I did not work because the PC did not recognise the USB floppy disk.

I just wonder if you could help me out.

Thank you
nzlexAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kgreeneitCommented:
a couple of things here, if you want your pc to recognise the usb floppy disk, you may need to go into your PC's BIOS (press either DEL or F2 at startup) and enable the setting USB Legacy devices.

The first thing to try though, would be to press F8 as the pc is booting up to get the advanced startup menu for Windows. From here, you can select the 'Last Known Good Configuration' option and see if this works.

If this doesn't work, then you will need your Windows 200 CDRom to carry out a Repair from the Recovery Console. Have a look at this link and follow the instructions:

http://www.windowsnetworking.com/j_helmig/wxprcons.htm

let me know if this helps.
0
nzlexAuthor Commented:
Hi there,

Thank you so much for the quick reply, I really appreciate it.

Do you have detail instructions for enabling the setting USB Legacy device?, My PC did not have a floppy drive, I borrow a USB floppy drive from a friend, I could not install the driver because my PC did not boot up.

Sure, I'll let you know if it works
Thank you very much indeed
0
kgreeneitCommented:
the setting for enabling usb legacy devices is usually in the computer BIOS setting of 'Peripherals' and you can access the BIOS by powering the pc on and then pressing either the DEL key or the F2 key (this depends on the BIOS that you have in your computer - it can change from manufacturer to manufacturer). Not all BIOS's have this setting and due to the different nature of each manufacturer's BIOS, you would have to go through each menu in the BIOS to see if you can find it.

I still feel that your best option of resolving this problem would be to use the Windows 2000 CDROM and carry out a repai using the recovery console as discussed above.

Hope this helps though.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jay_Jay70Commented:
Hi nzlex,

if the recovery console doesnt work, complete a repair install, not the recovery console but the actual repair option instead of installing a fresh install of windows

Cheers!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.