?
Solved

Enabling USB2.0  for an Archos ArcDisk20 on a Toshiba Portege 3110CT with Windows 98

Posted on 2006-03-25
6
Medium Priority
?
887 Views
Last Modified: 2008-01-09
I am looking for a way to connect an Archos ArcDisk20 (mb) USB2.0 hard drive to my Toshiba Portege 3110Ct with Windows 98.  The Archos uses an Hitachi_DK14FA-20 drive unit.

I ran the USB driver update WUCP from Windows 98 SP1 and I downloaded a driver from the Archos website for the hard drive.

The laptop recognises the Archos drive as drive D:(which I plug-in prior to startup) and the directory of the drive appears, but I cannot read or write from the Archos.  When I click to access a test file on the Archos I get a blue-screen error 'Disk Write Error Unable to write to disk in drive D, data or files may be lost. Press any key to continue'.  I wondering if the Portege USB port's power output is insufficient to power the Archos, or is there another problem?

When I power up with a 'generic' USB pen in the port, it isn't recognised at all.
0
Comment
Question by:mjordanb
  • 4
  • 2
6 Comments
 
LVL 93

Expert Comment

by:nobus
ID: 16293090
>>   I downloaded a driver from the Archos website    << was it an win98 driver?
In windows 98, your drive must be formatted FAT32, if it is formatted NTFS you cannot use it.
To use it , you need to partition and format it first. If there is data on it, back it up.
then go into disk management, select this drive and partition it, then format it. - all data will be lost
0
 

Author Comment

by:mjordanb
ID: 16293188
Thanks - the hard drive is FAT32.  The generic USB pen is 'FAT'.  Looking at my hardware profiles, the USB port on the portege is USB 1.0, while both these devices appear to be USB 2.0.  Could this be the problem or would the driver compensate?  I have ordered a PCMCIA USB 2.0 hub on eBay, to make the conversion.
0
 
LVL 93

Expert Comment

by:nobus
ID: 16293220
normally, when you connect a usb 2.0 device to an usb1.0 hub, it will only display the message that  you have a high speed device connected to a low speed port; but it is compatible.
And a usb 2.0 hub will not help speed up, since you still connect to the usb 1.0 port
and the driver ? was it an win98 driver? No win98 driver, no joy !
>>   When I power up with a 'generic' USB pen in the port  <<   do not power up with usb devices attached, it generates boot problems etc... Connect the device AFTER the power up

>>  it isn't recognised at all  <<  this points to a different Problem try this :
disconnect all usb devices, then :
in device manager, select view tab, and click "show hidden devices" - now in the general tab, delete ALL usb entries and reboot and test
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 93

Expert Comment

by:nobus
ID: 16293223
But correct me if wrong, this model does not have any usb ports? ? ?
0
 

Author Comment

by:mjordanb
ID: 16294167
Understand your points so far and thanks for your help so far.

I'm working on an XP machine, while I attempt to get the Toshiba Portege up and running, so I have been able to test my usb devices, which work on my XP desktop.

This European model of the Toshiba Portege has 1 usb port on the body of the machine and one on the docking station.

My copy of win98  (not win98se)  does not have a view tab in Device Manager.  The USB section only has one listing 'Universal serial bus controller'.  There are two subheadings:  'Intel 82440MX PCI to USB Universal Host Controller'  and 'USB Root Hub'

In the Toshiba Hardware section in the Control Panel, I have tried to get the machine to recoginse a USB pen with 'USB Legacy Emulation' truned off and turned on.  This is the problem I need to focus on first.

I think I need a win98 driver for the Archos, so I will proceed to look for one.

0
 
LVL 93

Accepted Solution

by:
nobus earned 1000 total points
ID: 16294586
You have a usb 1.0 port
you nedd a windows98 driver for the enclosure. If you don't find one, you're out of luck.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am not new to IT, I have been working in the field since 1985.  But recently I came up against something that stumped even me (it doesn't happen as often as I would like).  I was running a screencasting session from the laptop to my TV via ChromeC…
Lithium-ion batteries area cornerstone of today's portable electronic devices, and even though they are relied upon heavily, their chemistry and origin are not of common knowledge. This article is about a device on which every smartphone, laptop, an…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Screencast - Getting to Know the Pipeline
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question