WAP, ICS, Windows XP, Verizon Wireless Aircard

I am onsite trying resolve an issue. I have two new XP boxes; on one there is a small switch with a WAP plugged into that. The other PC is wireless. I installed a workgroup, shared the PC's. Everything was fine. I then installed a Verizon Broadband Aircard. Went in fine, connects to the internet; turned on ICS. Now my network is slightly hosed. I can ping each machine from the other, but all I get back is the IP address, then the Ping's time out. The other PC actually detects the broadband card and it's state, whether connected or disconnected, but if I open a browser on that machine, I get nothing.

I have disables firewall monitoring on both PCs, even in the advanced tab. I'm thinking the conflict may be between the WAP and the Aircard assigning IP's, but I'm not sure.

Urgent Help is an understatement.

Thanks.
thefunnydadAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Juan OcasioApplication DeveloperCommented:
I had the exact same issue when on a site.  Unfortunately, we were unable to resolve the issue and had to hose the Aircard (which was also verizon).  I believe it creates a conflict in the network and the only way we clould get back on our network was to disconnect from the Verizon service.  We were wired into the network, so the connection should have not been a problem.  Just to make sure, I would check your ICS connections again on all of the machines (maybe turn it off and then on again) to see if that resolves your issue.

I hope you're able to get it going!

jocasio
0
hfernCommented:
I think that this is most likely a routing problem. In order to find it, you'd need to provide the follwing information:
- For machine 1, which has the switch and the aircard: the IP address, subnet mask and default gw for the ethernet interface
- For machine 2: the IP address, subnet mask and the default gw
- For the WAP: IP address, subnet mask and the default gw
- All confuguration parameters of the aircard.

0
thefunnydadAuthor Commented:
Alrighty then, Well Jo, turning away isn't an option, but thanks for the input.

I'm not onsite any longer, but I can tell you the easy one, Machine 2 is simply set fully to "Auto Configure" for everything, DHCP on.

I think I have the WAP; IP 192.168.1.245, subnet, 255.255.255.0, DG, 192.168.1.1

For Machine 1, when I went to share the the aircard, it set the LAN connection to the WAP to an IP of 168.0.0.1 and a subnet gateway of 255.255.255.0.

I'm in the process of recreating the isuse on a network in my shop, but on a different Verizon card. This one is the next one down.

So far, I have been able to duplicate the part where a remote PC can initially see the the network shares and drill them, see the broadband connection and its state, but not access it. I have attempted running the netwok wizard, and it identifies the card on the remote machine, but even afterwards, the Internet was not accessable. I came back to the card and noticed under the firewall Advanced settings the boxes for the two connections were checked, so I have disabled the Firewall settings for both the wireless card and the Aircard. I need to disconnect and reconnect the Aircard and then give it a try; but if I can tell you anything about this setup here, let me know as so far it's doing the same thing.

thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

hfernCommented:
>For Machine 1, when I went to share the the aircard, it set the LAN connection to the
>WAP to an IP of 168.0.0.1 and a subnet gateway of 255.255.255.0.

I would suggest to set the IP addresses manually; use fixed IP addresses. This may avoid ICS from assigning different IP addresses and messing up your network. Basically you have just the one LAN segement. I suggest the following scheme:
- machine 1: IP address: 192.168.1.1, subnet mask 255.255.255.0 - do not define a default gw
- machine 2: IP address: 192.168.1.2, subnet mask 255.255.255.0, gw 192.168.1.1
- WAP: IP address 192.168.1.245, subnet mask 255.255.255.0
0
thefunnydadAuthor Commented:
OK here is what I have done. I have set the IP for the LAN connection on Machine 1 to what you said; That connection in turn goes to the WAP, which I set as instructed. I went to machine 2 and set that IP as well. I then shared the Aircard, which reset the IP for the lan to 192.168.0.1; I don't know much about networking, so I set it back to 192.168.1.1 I set ICS to use the local area connection.

Go to Explorer, can drill and ping machine 2

Go to Machine 2, can drill and ping machine 1, WAP as well. Go to network neighborhood properties, I can see the state of the Aircard as connected. Open a browser, nothing. Try to ping google.com from that machine, nothing. I am currently on the web on Machine 1, so I know we're connected. Likewise, if I disconnect, it will show the state as disconnected on Machine 2.

Boy, it seems like we are just so close. It HAS to be something simple. Somehow the last couple of times I have done this, I have been cheating and didn't realize it. Meaning I know the aircard will share the connection, but in those cases I never checked the network shares, which I doubt were working. In this case, we need both.

Thanks
0
hfernCommented:
Yeah I agree, we're close..
There is a problem with ICS not being able to fragment packets when the MTU size for the public network is smaller then the MTU size on the client machine. To test this out, can you do the following:

   ping -f -l 1500 <default gw address>

The default gw address is the IP address of the aircard. There are a few things to notice:
1. can it reach that IP address? If it does, can you also ping a known IP address on the Internet like 64.233.187.99 (which is google.com)? If this works, we may have a DNS problen and you may want to manually configure the DNS addresses of Verizon on machine 2.
2. does the packet go through unfragmented? If it needs to fragment, then repeat this with a lower value for '1500' Typically 1492 is used on PPPoE connections.

If you see the fragmenting then you need to adjust the MTU size of machine 2. The procedure is as follows:
1. Run the Registry Editor (REGEDIT.EXE) on machine 2.
2. Navigate to HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters\ Interfaces.
3. There should be several subkeys under the Interfaces key; most likely, you'll find three. View the contents of each key by clicking, and find the one that corresponds to your network adapter; it will be the one with more values than the other two, and will have an IP address value set to 192.168.1.2
3. Once you've found the correct subkey, create a new DWORD value in it (Edit -> New -> DWORD Value), and name the value MTU.
4. Double-click the new value, choose the Decimal option, and type the MTU value determined above.
5. Click Ok when you're done - you'll need to restart Windows for this change take effect.
0
thefunnydadAuthor Commented:
Here is my only real question before I get started; I set the IP address of 192.168.1.1 to the LAN adapter that services the WAP; NOT the Aircard. Was I supposed assign the settings to the Aircard, or the wired LAN adapter? That might have been my challenge. But also as I said, the ICS for the card actually modifies the settings for the wired LAN adapter, so I assumed that was right.

I will try the ping though from Machine 2.
0
hfernCommented:
You did right, I meant setting the address of the LAN card. The aircard should get it's IP address when it connects to Verizon.
One more thing that you may want to try is folliowing the address set up that ICS suggests and move your complete network to 192.168.0.x.. This would mean setting the IP address of machine 1 to 192.168.0.1 and the IP address of machine 2 to 192.168.0.2
0
thefunnydadAuthor Commented:
ok, I had thought the same thing while at church this morning, just flipping the schema to .0.1; I'll try that. Now the ping got me this:

"Packet needs to be fragmented but DF set" I got down to 1473 with this same message and at 1472 down to 1450, all time outs. I don't know what I was expecting, maybe a full ping return so I would know what MTU to set it at? Pings for the IP return, but not the full name. DNS?
0
hfernCommented:
OK, this indeed indicates that you have an MTU problem. Just go down further with the MTU value until you see a proper ping response.
Are you pinging the gateway or an IP address on the Internet?
0
thefunnydadAuthor Commented:
Each time I hookup to Verizon, I get a different IP address. That might be normal of course, but just an fyi, I didn't know how that would play into having to manually assign the DNS to machine 2. They are starting out 70.195.156.164, then the second one was the same, except the last number was 92.

I was going down in steps of one, for instance 1480, 1479, 1478 etc. sound right? I switched the schema to 0.1. but have not tried it yet, I am going to go try to find the MTU.
0
thefunnydadAuthor Commented:
ok, well. I found the MTU, set that in the registry. restarted. Drilling the network got faster, and I mean a LOT faster. but no go on the Internet; still the same conditions, can ping 64.233.187.99, but not www.google.com from a command prompt; can see the connection state of the Aircard on Machine 2, but nothing at the browser. For the MTU test, I was pinging the gateway.

For all those that follow, I was backing into the MTU, which was tedious, so to get a starting point I dropped down to like 1100, got a good ping then kept increasing by 100 until I hit the ceiling again, then backed into the maximum MTU. That proved much faster than stepping down 1 at a time from 1400; the MTU was 1272.
0
hfernCommented:
Good that you network got faster :-)

That you get different IP addresses from Verizon on the aircard each time you log in is normal. You do not have a fixed IP address. Verizon assigns an IP address to you from a pool of available IP addresses.

The remaining problem that you have is a DNS problem. DNS or Domain Name Servers are systems that convert host names like www.google.com into IP addresses like 64.233.187.99. If you can ping 64.233.187.99, but cannot ping www.google.com then DNS is not working. You ned to set the IP address of the Verizon Domain Name Servers on machine 2. You can get the IP addresses of the Domain Name Servers by issueing the following command on machine 1:

ipconfig /all

This address or addresses need to be configured in the IP interface of machine 2
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thefunnydadAuthor Commented:
Set JUST the the two DNS, ignore the gateway, or rather leave it at my current Gateway? This is what ipconfig /all returned:

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC
        Physical Address. . . . . . . . . : 00-02-3F-DB-B7-18
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.0.1
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

PPP adapter NationalAccess - BroadbandAccess:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
        Physical Address. . . . . . . . . : 00-53-45-00-00-00
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 70.194.241.214
        Subnet Mask . . . . . . . . . . . : 255.255.255.255
        Default Gateway . . . . . . . . . : 70.194.241.214
        DNS Servers . . . . . . . . . . . : 66.174.95.44
                                                   66.174.92.14
        NetBIOS over Tcpip. . . . . . . . : Disabled
0
hfernCommented:
Just set the DNS Servers on machine 2 to 66.174.95.44 and 66.174.92.14. Leave the default gw as is. (192.168.0.1)
BTW, if you have your system hooked up directly to the Internet then do make sure that your firewall is on on machine 1 and that your system is up to date with patch levels. It's a mean world out there..
0
thefunnydadAuthor Commented:
DUDE; like I owe you REAL money. Do you have a paypal account? Need part time consultation work? This all worked and the whole thing is grease lightening. I am assuming it will work in my other situation as well, because the only thing that is different is the Aircard, but like I said before, I was getting the exact same symptoms there that I was able to get here.

Now I have network AND shared wireless.

to recap (and to get more words into search results) if you have trouble sharing a wireless aircard, particularly verizon ones, but probably any of them, First, override DHCP and set everthing static. Assign the DNS of the provider to the DNS of the clients. For good measure, take the extra time to manually confgure your MTU, trust me it is worth it. Also, I found Windows XP had a lot less heartburn with turning on ICS if all extra network adapters are either disabled and or unplugged. For instance, I was trying to get this going on a Toshiba laptop with a WAP plugged into the LAN adapter, while the internal wireless card was also active. Proved to be to much; Windows kept freezing. I finally just disabled the Wireless, unplugged the LAN, forcing ICS to pick the empty LAN port. Shut it down, restarted and then went to the 2nd machine, set the DNS and BOOM; life is great.

Thanks hfern
0
thefunnydadAuthor Commented:
Will do, thanks!
0
hfernCommented:
Glad you got it working.

> Need part time consultation work?
As a matter of fact I am open for consultancy work.. Please drop me a note at hfern at bluebottle.com and we can discuss. Thanks.
0
thefunnydadAuthor Commented:
Well, this didn't work in deployment; I am able to get to the aircard from the clients, but cannt drill the network. Same symptoms apply. If you happen to read this hfren, I sent you an e-mail. If anyone else can she any light, please let me know and I will open another question so I can award points again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.