Linux : rsh Permission denied error


Hi Experts,

                   I'm trying to do rsh on my machime 'A' from machine 'B'.  I do not have any  firewall on machine  'A' and also port 514 is open.

when I try to do the rsh I'm getting permission denied.
 
 # rsh 192.168.1.76 -l shashi /bin/ls
permission denied.


Please help me out..



expertblrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

leisnerCommented:
You need to edit the ~/.rhosts file on the rmote machine.

You may also set it globally in /etc/hosts.equiv.

There is supposed to be a man page rhosts(5) but I don't have it on fedora3 it seems...
Here's something to get you started:
http://www.daemon-systems.org/man/rhosts.5.html

.rhosts also cannot be r/w by anyone except you.

0
expertblrAuthor Commented:

I created the ~/.rhosts file  and then tried to do the rsh. But, still I'm getting permission denied......

I just added my machines IP address in .rhosts file of the remote machine. Is  there any syntax to follow for adding the Ip in the .rhosts file?
0
leisnerCommented:
no, is  it rw-- --- ---?

I've found there are a number of "things"  that have to be
working right to get this working...

I assume you have the same user names on both machines
(you can configure so one user on another machine can get access to your account).

Also try:
    rsh remote pwd   (to show pwd)
    rsh remote          (to login)

If the local machine also supports rsh, you can also do
it the other way and try it the other way.

To understand what is wrong, I often found it helpful to sniff the packets with ethereal -- you can also do things like
    rsh localhost
(which is really rlogin)

the rtools are very handy in a permissive environment....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
expertblrAuthor Commented:
Hi leisner,

     It started working. the problem was rlogin was not enabled....enabled it now.


Thanks,
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.